Bug 184898 - LTC23474 kdump crashed on 16 logical CPU SCSI server (4G mem)
LTC23474 kdump crashed on 16 logical CPU SCSI server (4G mem)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 03:48 EST by Fei Fei
Modified: 2009-09-08 23:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 15:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial port capture when crash happens (60.29 KB, text/plain)
2006-03-10 03:48 EST, Fei Fei
no flags Details
kdump-mpt-fusion-driver-hardening-fix.patch (5.21 KB, text/plain)
2006-05-23 15:22 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Fei Fei 2006-03-10 03:48:08 EST
Description of problem:
When testing kdump on a 4 packages * multi-core * hyper-threading (16 logical
CPU total) server system, kernel panic occured. Serial port output attached in
this bug.



Version-Release number of selected component (if applicable):
>kernel-kdump-2.6.15-1.1955_FC5.i686.rpm
>kexec-tools-1.101-7.1.1.i386.rpm
>kernel-debuginfo-2.6.15-1.1955_FC5.i586.rpm


How reproducible:
echo c > /proc/sysrq-trigger


Steps to Reproduce:
1. echo c > /proc/sysrq-trigger
2.
3.
  
Actual results:
Kernel crash with serail port result captured in attachment

Expected results:
kdump works fine and dump analysis can work.


Additional info:

Physical memory of the machine: 4G
Arch of OS: IA32
Comment 1 Fei Fei 2006-03-10 03:48:08 EST
Created attachment 125936 [details]
serial port capture when crash happens
Comment 2 IBM Bug Proxy 2006-05-22 16:37:01 EDT
Connecting the IBM ltc bugzilla number bug#23474 with this bug. Thanks.
Comment 3 IBM Bug Proxy 2006-05-23 15:15:08 EDT
----- Additional Comments From vivegoya@in.ibm.com  2006-05-23 12:40 EDT -------
I can not reproduce the same problem but I could reproduce the different one.
Both  the problems seems to be originating from same problem source and that is,
mpt fusion adapter has its interrupt line asserted while the mpt fusion driver
is initializing in the second kernel. Probably we need to reset the underlying
device before request_irq() is called.

I have posted a patch for the issue which is in -mm now. Andrew had sent it to
James Bottomley.

http://marc.theaimsgroup.com/?l=linux-scsi&m=114613061229295&w=2 
Comment 4 IBM Bug Proxy 2006-05-23 15:22:55 EDT
Created attachment 129884 [details]
kdump-mpt-fusion-driver-hardening-fix.patch
Comment 5 IBM Bug Proxy 2006-05-23 15:23:19 EDT
----- Additional Comments From vivegoya@in.ibm.com  2006-05-23 12:43 EDT -------
 
Attaching the patch posted to fix the problem.

This is the fix patch posted to lkml and is now in -mm. 
Comment 6 Vivek Goyal 2006-07-11 15:38:16 EDT
This problem is resolved and fix is available in kernel-2.6.17-1.2365.fc6

The fix is also mainline and available in 2.6.18-rc1. 

Marking the bug as "resolved"
Comment 7 IBM Bug Proxy 2006-09-28 04:26:16 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED




------- Additional Comments From smaneesh@in.ibm.com (prefers email at maneesh@in.ibm.com)  2006-09-28 04:20 EDT -------
Patch merged with RHEL5 beta1. Closing 

Note You need to log in before you can comment on or make changes to this bug.