Bug 1849265 - not able to open .dxf-file with qcad from Nautilus
Summary: not able to open .dxf-file with qcad from Nautilus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qcad
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-20 06:44 UTC by Pontus Enhager
Modified: 2020-07-06 01:39 UTC (History)
2 users (show)

Fixed In Version: qcad-3.24.3.0-2.fc32 qcad-3.24.3.0-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-01 01:49:08 UTC
Type: Bug


Attachments (Terms of Use)
an example .dxf file (21.27 KB, image/vnd.dxf)
2020-06-20 10:50 UTC, Pontus Enhager
no flags Details

Description Pontus Enhager 2020-06-20 06:44:44 UTC
Description of problem:
if you find e.g. a .dxf file you would like to check out when browsing in Nautilus you would like to be able to open it with a mouse click. right now you cant

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.find .dxf file in nautilus
2.you cannot find qcad in the "open file with" menu
3.

Actual results:
Not able to open as intended with ny favourite 2D-cad program

Expected results:
success

Additional info:

in the .desktop file - please add an %U to the Exec line

that is:
-Exec=qcad
+Exec=qcad %U

(at least that solve the problem for me, might be better solutions out there)

Comment 1 Antonio T. sagitter 2020-06-20 10:43:21 UTC
Hi Pontus.

Please, can you attach a .dxf file for testing?

Comment 2 Pontus Enhager 2020-06-20 10:50:41 UTC
Created attachment 1698194 [details]
an example .dxf file

Comment 3 Pontus Enhager 2020-06-20 11:08:00 UTC
to be clear (and likely overexplanatory), qcad have no difficulty opening the file as such from the open file dialog - the problem is just that the program does not tell the desktop environment that it is an application that can open files, hence clicking on files in nautilus will not give me the opportunity to open it by any means, and the only option given by Gnome is ironically that it recommends me to install librecad to be able to open it.

Comment 4 Fedora Update System 2020-06-20 15:39:28 UTC
FEDORA-2020-2a2692478a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-2a2692478a

Comment 5 Antonio T. sagitter 2020-06-20 15:42:58 UTC
Thank you Pontus.

Comment 6 Pontus Enhager 2020-06-21 07:27:22 UTC
my pleasure, thanks

Comment 7 Fedora Update System 2020-06-23 01:03:53 UTC
FEDORA-2020-2a2692478a has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-2a2692478a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-2a2692478a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-06-27 18:44:31 UTC
FEDORA-2020-419d6fc367 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-419d6fc367

Comment 9 Fedora Update System 2020-06-28 01:56:22 UTC
FEDORA-2020-419d6fc367 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-419d6fc367`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-419d6fc367

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-07-01 01:49:08 UTC
FEDORA-2020-2a2692478a has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-07-06 01:39:26 UTC
FEDORA-2020-419d6fc367 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.