Bug 1849836 - please include libtar-devel in CRB
Summary: please include libtar-devel in CRB
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libtar
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Kamil Dudka
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-22 23:09 UTC by Orion Poplawski
Modified: 2021-03-21 14:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-21 14:49:23 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 17330 0 None None None 2020-06-23 13:15:19 UTC

Description Orion Poplawski 2020-06-22 23:09:14 UTC
Description of problem:

Please consider building libtar for EPEL8.  If you are not interested in maintaining it in EPEL, please add me (FAS orion) as an admin on the package so that I can request the EPEL8 branch.  Thanks.

Seems to build fine:
https://koji.fedoraproject.org/koji/taskinfo?taskID=46003675

Comment 1 Kamil Dudka 2020-06-23 07:07:05 UTC
libtar cannot be built for EPEL-8 because it is in RHEL-8.  This is technically a request to include libtar-devel into CRB repo as I understand it.  Is there any customer case behind this request?

Comment 2 Orion Poplawski 2020-06-23 13:15:19 UTC
Ah, I missed that.  I'm afraid I'm not a customer.  I need it to build NetDRMS used to process JSOC data (http://jsoc.stanford.edu/), but I doubt any of the other JSOC sites are Red Hat customers either.  I see that there is already a request for CentOS to provide it and I've linked to that here as well.

Comment 3 Kamil Dudka 2020-06-23 13:40:40 UTC
Thank you for adding the reference to the corresponding CentOS bug.

Comment 5 Kamil Dudka 2021-03-21 14:49:23 UTC
The libtar package is no longer maintained upstream.  The last activity in the upstream git repository was in 2013.  We are currently migrating off libtar (see bug #1917890 for details), so it is unlikely that Red Hat would ever want to support libtar in RHEL-8 CRB.  I am closing this bug as WONTFIX.  Although the package may theoretically appear in EPEL-9, I would discourage from using it.


Note You need to log in before you can comment on or make changes to this bug.