Bug 18502 - crashes during kickstart install
Summary: crashes during kickstart install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 06:57 UTC by Daniel Wittenberg
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-13 21:42:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart traceback (732.00 KB, application/octet-stream)
2000-10-06 14:56 UTC, Daniel Wittenberg
no flags Details
kickstart file (2.03 KB, text/plain)
2000-11-07 20:27 UTC, Daniel Wittenberg
no flags Details

Description Daniel Wittenberg 2000-10-06 06:57:23 UTC
While trying to run an automated install with kickstart anaconda crashes
during the "reading packages" part.  Can provide dd of floppy dump/debug if
needed.

Comment 1 Daniel Roesen 2000-10-06 08:34:13 UTC
Please do so. Just create a new attachment with the traceback.

Comment 2 Daniel Wittenberg 2000-10-06 14:56:19 UTC
Created attachment 3840 [details]
kickstart traceback

Comment 3 Michael Fulbright 2000-10-06 18:14:38 UTC
I've included the contents of the dump file - you don't need to dd the whole
disk for future reference:
 
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 365, in
__call__
    todo.getCompsList ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 540, in
getCompsList
    self.updateInstClassComps()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 575, in
updateInstClassComps
    self.selectPackage(n)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 586, in
selectPackage
    raise ValueError, str
ValueError: package ispell is not available

Local variables in innermost frame:
package: ispell
str: package ispell is not available
self: <todo.ToDo instance at 82b3578>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Comment 4 Michael Fulbright 2000-10-06 18:15:11 UTC
Is this a self-made CD? My guess this is a dupe of bug 18031.

Comment 5 Daniel Wittenberg 2000-10-06 20:13:04 UTC
This was a iso-burned image, I'll see if I can whip up another CD and give it
another shot...worst case I'll buy one.

Comment 6 Daniel Wittenberg 2000-10-07 05:38:15 UTC
Failed once again.  I downloaded a new .iso, burned it at 1x, verification came
back with no errors, but anaconda still dies.  Here's the latest dump:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 365, in
__call__
    todo.getCompsList ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 540, in
getCompsList
    self.updateInstClassComps()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 575, in
updateInstClassComps
    self.selectPackage(n)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 586, in
selectPackage
    raise ValueError, str
ValueError: package libgr-devel is not available

Local variables in innermost frame:
package: libgr-devel
str: package libgr-devel is not available
self: <todo.ToDo instance at 8275838>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Comment 7 Daniel Wittenberg 2000-10-16 23:19:46 UTC
I just got my box set today, and tried with the actualy RH cd and same thing
happens

Comment 8 Michael Fulbright 2000-10-27 16:49:54 UTC
Could you give us step by step instructions on how to reproduce this problem?



Comment 9 Daniel Wittenberg 2000-11-07 05:05:45 UTC
I copied the ks.cfg to a standard boot floopy, then boot: linux ks=floppy.  Not
sure what other info you need ?

Comment 10 Michael Fulbright 2000-11-07 19:40:54 UTC
Please attach your kickstart file.

Comment 11 Daniel Wittenberg 2000-11-07 20:27:05 UTC
Created attachment 5139 [details]
kickstart file

Comment 12 Michael Fulbright 2000-11-13 20:57:40 UTC
Passed to QA to reproduce.

Comment 13 Brock Organ 2000-11-13 21:42:41 UTC
your kickstart file (I am guessing) was generated by mkkickstart ... or at least
something similar was used to generate your package list, as you have packages
in that list that are not available in Red Hat Linux 7 ...

for example, ispell (as in your error above) is no longer available, similarly
packages like libgr, libgr-devel, egce-c++, etcskel, etc. are not valid install
package candidates ...

Have you considered using package groupings ...? 

You can specify predefined groups of packages such as:

%packages
@Base
@X Window System
@GNOME Workstation

to install useful sets of packages ...

hope this helps ... thanks for your report!


Note You need to log in before you can comment on or make changes to this bug.