Bug 185121 - banshee daap plugin fails to work due to selinux policy
banshee daap plugin fails to work due to selinux policy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 14:45 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 11:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-03-10 14:45:21 EST
Description of problem:

banshee daap plugin is denied access to dbus:

zero> banshee --debug
** Running Banshee in Debug Mode **
Warning: [3/10/2006 2:22:15 PM] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Player Engine `Helix Framework Engine (hxclientkit)' failed init tests...
disabling (Couldn't create player)
Debug: [3/10/2006 2:22:15 PM] (Changed active playback engine) - GStreamer 0.10
Debug: [3/10/2006 2:22:15 PM] (Loaded primary playback engine) - GStreamer 0.10
Debug: [3/10/2006 2:22:15 PM] (Loaded Audio CD playback engine) - GStreamer
0.10Warning: [3/10/2006 2:22:15 PM] (HAL context could not be created) - Could
not get device list from HAL; D-Bus may not be working or configured properly
Warning: [3/10/2006 2:22:15 PM] (Audio CD support will be disabled for this
instance) - HAL is not initialized
Warning: [3/10/2006 2:22:15 PM] (DAP support will be disabled for this instance)
- Cannot initialize DapCore because HalCore is not initialized
Warning: [3/10/2006 2:22:15 PM] (Could not initialize plugin `Daap') - Access denied
Debug: [3/10/2006 2:22:15 PM] (Registering Inotify watch) - /net/home/rcc/tjb/Music/
Starting Inotify threads
Warning: [3/10/2006 2:22:16 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: An SELinux policy prevents this sender from
sending this message to this recipient (rejected message had interface
"org.freedesktop.DBus" member "Hello" error name "(unset)" destination
"org.freedesktop.DBus")



Version-Release number of selected component (if applicable):

selinux-policy-targeted-2.2.23-15

How reproducible:

everytime on multiple systems

Steps to Reproduce:
1. run banshee
2.
3.
  
Actual results:
Daap plugin fails to initialize.

Expected results:
Daap plugin works.

Additional info:
Comment 1 Thomas J. Baker 2006-03-10 14:47:42 EST
Not sure if this is an selinux problem after all as nothing is logged to the
audit log.
Comment 2 Daniel Walsh 2006-03-10 16:49:42 EST
Try it with setenforce 0.  If it works, probably SELinux, if not then probably
someone elses.
Comment 3 Thomas J. Baker 2006-03-11 08:22:56 EST
In permissive mode, the daap plugin does initialize correctly.
Comment 4 Thomas J. Baker 2006-03-15 09:35:57 EST
With enforcing mode, I don't see errors in the audit.log but going into
permissive mode, I get many errors. audit2allow converts those errors into these:

[tjb@zero tjb]# tail -200 /var/log/audit/audit.log | audit2allow
allow avahi_t mono_t:dbus send_msg;
allow hald_t automount_tmp_t:dir search;
allow hald_t default_t:dir getattr;
allow hald_t mono_t:dbus send_msg;
allow mono_t avahi_t:dbus send_msg;
allow mono_t hald_t:dbus send_msg;
[tjb@zero tjb]#

Comment 5 Thomas J. Baker 2006-03-23 09:06:28 EST
Changed to an fc5 bug from devel.
Comment 6 Daniel Walsh 2006-04-03 10:04:35 EDT
Fixed in 2.2.29-2.fc5
Comment 8 Daniel Walsh 2006-05-05 11:06:12 EDT
Closing as these have been marked as modified, for a while.  Feel free to reopen
if not fixed

Note You need to log in before you can comment on or make changes to this bug.