Bug 18515 - Installation fails on FTP install
Installation fails on FTP install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 08:10 EDT by crusoe
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-31 14:11:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description crusoe 2000-10-06 08:10:46 EDT
Here's some cut'n paste from my anacond.txt file:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/urlinstall.py", line 27,
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 353, in
readCompsFile
  File "/tmp/lib/python1.5/urllib.py", line 59, in urlopen
    return _urlopener.open(url)
  File "/tmp/lib/python1.5/urllib.py", line 159, in open
    return getattr(self, name)(url)
  File "/tmp/lib/python1.5/urllib.py", line 360, in open_ftp
    host = socket.gethostbyname(host)
IOError: [Errno socket error] host not found

Local variables in innermost frame:
port: None
self: <urllib.FancyURLopener instance at 83326b8>
path:
/pub/os/Linux/distributions/redhat/releases/guinness/i386/en/RedHat/base/comps
url:
//ftp.sunet.se/pub/os/Linux/distributions/redhat/releases/guinness/i386/en/RedHat/base/comps
passwd: 
user: 
host: ftp.sunet.se

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://ftp.sunet.se/pub/os/Linux/distributions/redhat/releases/guinness/i386/en'
sbsS'initlevel'
p7
I3
sS'skipLilo'
p8
I0
sS'progressWindow'
p9
NsS'expert'
p10
I0
sS'ddruidReadOnly'
p11
I0
sS'bootdisk'
p12
I0
sS'language'
p13
(itodo
Language
(dp14
S'abbrevMap'
p15
(dp16
S'es_ES'
p17
S'Spanish'
p18
sS'tr_TR'
p19
S'Turkish'
p20
sS'sr_YU'
p21
S'Serbian'
p22
sS'de_DE'
p23
S'German'
p24
sS'sk_SK'
p25
S'Slovak'
p26
sS'ru_RU.KOI8-R'
p27
S'Russian'
p28
sS'is_IS'
p29
S'Icelandic'
p30
sS'no_NO'
p31
S'Norwegian'
p32
sS'sv_SE'
p33
S'Swedish'
p34
sS'en_US'
p35
S'English'
p36
sS'it_IT'
p37
S'Italian'
p38
sS'da_DK'
p39
S'Danish'
p40
sS'cs_CZ'
p41
S'Czech'
p42
sS'uk_UA.KOI8-U'
p43
S'Ukrainian'
p44
sS'hu_HU'
p45
S'Hungarian'
p46
sS'fr_FR'
p47
S'French'
p48
sS'sl_SI'
p49
S'Slovenian'
p50
sS'ro_RO'
p51
S'Romanian'
p52
ssS'font'
p53
(dp54
g38
S'lat0-sun16'
sg22
S'cyr-sun16'
sg28
S'cyr-sun16'
sg36
S'None'
sg26
S'lat2-sun16'
sg32
S'lat0-sun16'
sg34
S'lat0-sun16'
sg48
S'None'
sg50
S'lat2-sun16'
sg52
S'lat2-sun16'
sg24
S'None'
sg20
S'lat5-sun16'
sg46
S'lat2-sun16'
sg18
S'None'
sg44
S'cyr-sun16'
sg42
S'lat2-sun16'
sg40
S'lat0-sun16'
sg30
S'lat0-sun16'
ssS'langs'
p55
(dp56
g38
g37
sg22
g21
sg28
g27
sg36
g35
sg26
g25
sg32
g31
sg34
g33
sg48
g47
sg50
g49
sg52
g51
sg24
g23
sg20
g19
sg46
g45
sg18
g17
sg44
g43
sg42
g41
sg40
g39
sg30
g29
ssS'info'
p57
(dp58
S'LANG'
p59
g35
ssS'map'
p60
(dp61
g38
S'iso15'
sg22
S'iso05'
sg28
S'koi8-r'
sg36
S'None'
sg26
S'iso02'
sg32
S'iso15'
sg34
S'iso15'
sg48
S'None'
sg50
S'iso02'
sg52
S'iso02'
sg24
S'None'
sg20
S'iso09'
sg46
S'iso02'
sg18
S'None'
sg44
S'koi8-u'
sg42
S'iso02'
sg40
S'iso15'
sg30
S'iso15'
ssS'lang'
p62
g35
sbsS'fstab'
p63
NsS'lilo'
p64
(ililo
LiloConfiguration
(dp65
S'liloDevice'
p66
S'partition'
p67
sS'initrdsMade'
p68
(dsS'edd'
p69
I0
sS'default'
p70
S'dos'
p71
sS'liloImages'
p72
(dp73
S'hda1'
p74
(g71
I1
tsS'hda3'
p75
(S'linux'
p76
I2
tssS'liloLinear'
p77
I1
sS'liloAppend'
p78
NsbsS'comps'
p79
NsS'network'
p80
(itodo
Network
(dp81
S'netdevices'
p82
(dp83
S'eth0'
p84
(itodo
NetworkDevice
(dp85
g57
(dp86
S'ONBOOT'
p87
S'no'
sS'IPADDR'
p88
S'195.42.198.183'
sS'BOOTPROTO'
p89
S'static'
sS'NETMASK'
p90
S'255.255.255.0'
sS'DEVICE'
p91
g84
ssbssS'gateway'
p92
S'195.42.198.254'
sS'secondaryNS'
p93
S''
sS'hostname'
p94
S'ninja'
sS'primaryNS'
p95
S'195.42.198.5'
sS'domains'
p96
(lsS'isConfigured'
p97
I1
sS'readData'
p98
I1
sS'ternaryNS'
p99
S''
sbsS'upgrade'
p100
I0
sS'instClass'
p101
(icustom
InstallClass
(dp102
S'rootPasswordCrypted'
p103
I0
sS'nameserver'
p104
S''
sS'x'
NsS'rootPassword'
p105
NsS'makeBootdisk'
p106
I0
sS'installType'
p107
NsS'postScript'
p108
NsS'earlySwapOn'
p109
I0
sS'networkDevice'
p110
NsS'clearText'
p111
Nsg64
(S'mbr'
p112
I1
S''
tsg13
NsS'name'
p113
S''
sS'postInChroot'
p114
I0
sS'pixmap'
p115
S''
sS'partitions'
p116
(lsS'clearType'
p117
Nsg92
S''
sS'mouse'
p118
NsS'packages'
p119
NsS'timezone'
p120
NsS'zeroMbr'
p121
I0
sS'keyboard'
p122
NsS'groups'
p123
NsS'bootProto'
p124
NsS'netmask'
p125
S''
sS'raidList'
p126
(lsS'skipSteps'
p127
(dsS'auth'
p128
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg94
Nsg63
(lsS'showgroups'
p129
NsS'ip'
p130
S''
sS'defaultRunlevel'
p131
NsS'desktop'
p132
S''
sS'clearPartText'
p133
NsS'clearParts'
p134
I0
sbsS'rootpassword'
p135
NsS'extraModules'
p136
(lp137
sg118
(imouse
Mouse
p138
(dp139
S'device'
p140
S'psaux'
p141
sg57
(dp142
S'XMOUSETYPE'
p143
S'PS/2'
p144
sS'FULLNAME'
p145
S'Generic - 3 Button Mouse (PS/2)'
p146
sS'MOUSETYPE'
p147
S'ps/2'
p148
ssS'emu'
p149
I0
sS'wasProbed'
p150
I1
sS'emulate'
p151
I1
sbsS'ddruidAlreadySaved'
p152
I0
sS'serial'
p153
I0
sg120
(S'Europe/Stockholm'
I1
I0
tsg121
I0
sg122
(ikbd
Keyboard
(dp154
S'layout'
p155
NsS'model'
p156
NsS'type'
p157
S'PC'
p158
sg57
(dp159
S'KEYBOARDTYPE'
p160
S'pc'
p161
sS'KEYTABLE'
p162
S'se-latin1'
p163
ssbsS'skipFdisk'
p164
I0
sS'fdDevice'
p165
S'fd0'
p166
sS'installSystem'
p167
I1
sS'setupFilesystems'
p168
I1
sg128
(itodo
Authentication
(dp169
S'useNIS'
p170
I0
sS'nisServer'
p171
S''
sS'useLdap'
p172
I0
sS'krb5Kdc'
p173
S''
sS'useHesiod'
p174
I0
sS'ldapServer'
p175
S''
sS'nisDomain'
p176
S''
sS'krb5Realm'
p177
S''
sS'useLdapauth'
p178
I0
sS'hesiodRhs'
p179
S''
sS'useShadow'
p180
I1
sS'nisuseBroadcast'
p181
I0
sS'useKrb5'
p182
I0
sS'useMD5'
p183
I1
sS'ldapBasedn'
p184
S''
sS'krb5Admin'
p185
S''
sS'hesiodLhs'
p186
S''
sS'hesiodDlhs'
p187
S''
sbsg94
NsS'reconfigOnly'
p188
I0
sS'x'
(ixf86config
XF86Config
(dp189
S'monlist'
p190
(dsS'keyModel'
p191
S'pc102'
p192
sS'monids'
p193
(dsg140
NsS'monEisa'
p194
NsS'server'
p195
NsS'monHoriz'
p196
S'31.5'
p197
sS'devID'
p198
NsS'modes'
p199
(dp200
S'8'
(lp201
S'640x480'
p202
assS'keyOptions'
p203
S''
sS'keyVariant'
p204
S''
sS'monID'
p205
S'Unprobed Monitor'
p206
sS'keyLayout'
p207
S'se'
p208
sS'manualModes'
p209
(dsg118
g138
sS'keyRules'
p210
S'xfree86'
p211
sS'monVert'
p212
S'60'
p213
sS'cardMan'
p214
NsS'monSect'
p215
S''
sS'primary'
p216
I0
sS'vidRam'
p217
NsS'probed'
p218
I0
sS'monName'
p219
NsS'vidCards'
p220
(lsS'skip'
p221
I0
sS'files'
p222
S'\012# The location of the RGB database.  Note, this is the name of
the\012# file minus the extension (like ".txt" or ".db").  There is
normally\012# no need to change the default.\012\012   
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and
later now use a font server independent of\012# the X server to render
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012   
FontPath   "unix/:7100"\012'
p223
sbsS'users'
p224
NsS'instPath'
p225
S'/mnt/sysimage'
p226
sS'intf'
p227
NsS'hdList'
p228
Nsb.
Comment 1 Michael Fulbright 2000-10-06 12:38:20 EDT
Please verify Brent.

Most likely your machine couldn't do a DNS lookup on the ftp server.

The bug is then we should handle this better than a traceback.
Comment 2 Brent Fox 2000-10-06 16:20:44 EDT
I was unable to reproduce this bug.  I was able to do an FTP install from
ftp.sunet.se with no problems.  At what point did your install fail?  Were you
ever connected to ftp.sunet.se at all?

Also, it looks like the traceback is coming from urllib.py, which is a Python
library module...not part of anaconda.  The bug *may* be in the Python library
instead.  

Comment 3 Brent Fox 2000-10-31 14:11:45 EST
I think that you had intermittent nameserver problems.  If you try to install
via that method again, it will probably work.  However, we will catch the error
before the installer tracebacks.


Note You need to log in before you can comment on or make changes to this bug.