Bug 185150 - crash when importing mbox
crash when importing mbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 16:49 EST by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 15:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-03-10 16:49:22 EST
Description of problem:
evolution segfaulted when importing unix mbox format email.

Version-Release number of selected component (if applicable):
evolution-2.5.92-1
gtk2-2.8.14-1
glib-1.2.10-18.2.2

How reproducible:
always

Steps to Reproduce:
1.start evolution
2.import single file
3.unix mbox format
Willing to upload 5m mbox file if stack trace is insufficient.
  
Actual results:
evolution segfaulted, stack trace with debug symbols attached below

Expected results:
successful import of mbox formatted email

Additional info:
#0  0x0000003d2a5128b1 in g_uri_list_extract_uris ()
   from /usr/lib64/libglib-2.0.so.0
#1  0x0000003d2a513031 in g_filename_from_uri ()
   from /usr/lib64/libglib-2.0.so.0
#2  0x00002b3e5989fdef in mbox_import (ei=0x9d4280, target=0xa57100, im=Variable
"im" is not available.
)
    at evolution-mbox-importer.c:197
#3  0x0000000000410a90 in import_druid_finish (page=Variable "page" is not
available.
) at e-shell-importer.c:531
#4  0x0000003d2a70b21d in g_closure_invoke ()
   from /usr/lib64/libgobject-2.0.so.0
#5  0x0000003d2a71af38 in g_signal_override_class_closure ()
   from /usr/lib64/libgobject-2.0.so.0
#6  0x0000003d2a71c383 in g_signal_emit_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#7  0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#8  0x0000003d2a70b21d in g_closure_invoke ()
   from /usr/lib64/libgobject-2.0.so.0
#9  0x0000003d2a71af38 in g_signal_override_class_closure ()
   from /usr/lib64/libgobject-2.0.so.0
#10 0x0000003d2a71c383 in g_signal_emit_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#11 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#12 0x000000380086a7ca in gtk_button_key_release (widget=Variable "widget" is
not available.
) at gtkbutton.c:1310
#13 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x691c50,
    return_value=0x7fffffc55170, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
---Type <return> to continue, or q <return> to quit---
#14 0x0000003d2a70b21d in g_closure_invoke ()
   from /usr/lib64/libgobject-2.0.so.0
#15 0x0000003d2a71b548 in g_signal_override_class_closure ()
   from /usr/lib64/libgobject-2.0.so.0
#16 0x0000003d2a71c14d in g_signal_emit_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#17 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#18 0x00000038009fd5de in gtk_widget_event_internal (widget=0x93fc50,
    event=0xa80e00) at gtkwidget.c:3732
#19 0x000000380091d9d3 in IA__gtk_propagate_event (widget=0x93fc50,
    event=0xa80e00) at gtkmain.c:2151
#20 0x000000380091e951 in IA__gtk_main_do_event (event=0xa80e00)
    at gtkmain.c:1422
#21 0x000000380064665c in gdk_event_dispatch (source=Variable "source" is not
available.
) at gdkevents-x11.c:2291
#22 0x0000003d2a526f7a in g_main_context_dispatch ()
   from /usr/lib64/libglib-2.0.so.0
#23 0x0000003d2a52a105 in g_main_context_check ()
   from /usr/lib64/libglib-2.0.so.0
#24 0x0000003d2a52a42d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#25 0x0000003d3032d2c6 in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#26 0x000000000041632a in main (argc=Variable "argc" is not available.
) at main.c:610
#27 0x0000003d2941d084 in __libc_start_main () from /lib64/libc.so.6
#28 0x000000000040a8a9 in _start ()
#29 0x00007fffffc55c48 in ?? ()
---Type <return> to continue, or q <return> to quit---
#30 0x0000000000000000 in ?? ()
Comment 1 Matthew Barnes 2006-09-21 15:44:36 EDT
Hi Scott, sorry it took so long for someone to look at this bug.

Before you upload your 5 MB mbox file, can I have you try this again and see if
it still crashes?  Also, what distro are you using now... Fedora Core 5 or Rawhide?
Comment 2 Scott Tsai 2006-09-22 15:08:14 EDT
Good news, I was unable to reproduce this on both my x86_64 fc5 and i386 rawhide
sysetms.
So the bug is apparently fixed.
Comment 3 Matthew Barnes 2006-09-22 15:12:38 EDT
Good, I'll close this bug then.  Feel free to re-open it if you encounter the
problem again.

Note You need to log in before you can comment on or make changes to this bug.