Bug 185178 - crash with backtrace
crash with backtrace
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-11 02:43 EST by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-06 15:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-03-11 02:43:19 EST
Description of problem:
liferea segfaulted, could not trigger again.

Version-Release number of selected component (if applicable):
liferea-1.0.7-2.fc5.x86_64

How reproducible:
hard

Steps to Reproduce:
1.start liferea
  
Actual results:
crashed with segfault

Expected results:
not crashing

Additional info:
#0  0x0000003d29475b04 in memcpy () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003d29475b04 in memcpy () from /lib64/libc.so.6
#1  0x0000003800641250 in _gdk_x11_convert_to_format (src_buf=Variable "src_buf"
is not available.
) at /usr/include/bits/string3.h:51
#2  0x0000003800642066 in gdk_x11_draw_pixbuf (drawable=0x638240, gc=Variable
"gc" is not available.
) at gdkdrawable-x11.c:1375
#3  0x0000003800633c7d in gdk_window_draw_pixbuf (drawable=0x5955b0,
gc=0x63b900, pixbuf=0x9e1b20, src_x=0, src_y=0, dest_x=115, dest_y=6, width=24,
    height=24, dither=GDK_RGB_DITHER_NORMAL, x_dither=-109, y_dither=-26) at
gdkwindow.c:2020
#4  0x0000003800903684 in gtk_image_expose (widget=0x62d0e0, event=0x6ea990) at
gtkimage.c:1777
#5  0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa29fd0, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#6  0x0000003d2a70b2ea in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x00000038009fd5de in gtk_widget_event_internal (widget=0x62d0e0,
event=0x6ea990) at gtkwidget.c:3732
#11 0x000000380089cf71 in IA__gtk_container_propagate_expose (container=Variable
"container" is not available.
) at gtkcontainer.c:2464
#12 0x000000380089d9ce in gtk_container_expose (widget=0x62d190, event=0x6ea6d0)
at gtkcontainer.c:2375
#13 0x0000003800868e04 in gtk_button_expose (widget=0x62d190, event=0x6ea6d0) at
gtkbutton.c:1238
#14 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa2a6a0, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#15 0x0000003d2a70b2ea in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#16 0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#17 0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#18 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#19 0x00000038009fd5de in gtk_widget_event_internal (widget=0x62d190,
event=0x6ea6d0) at gtkwidget.c:3732
#20 0x000000380089cf71 in IA__gtk_container_propagate_expose (container=Variable
"container" is not available.
) at gtkcontainer.c:2464
#21 0x000000380089d9ce in gtk_container_expose (widget=0x5baaa0, event=0x6eaa70)
at gtkcontainer.c:2375
#22 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa2ad50, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#23 0x0000003d2a70b2ea in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#24 0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#25 0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#26 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#27 0x00000038009fd5de in gtk_widget_event_internal (widget=0x5baaa0,
event=0x6eaa70) at gtkwidget.c:3732
#28 0x000000380089cf71 in IA__gtk_container_propagate_expose (container=Variable
"container" is not available.
) at gtkcontainer.c:2464
#29 0x00000038009be366 in gtk_toolbar_expose (widget=0x607000, event=0x99b080)
at gtktoolbar.c:3999
#30 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa2b440, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#31 0x0000003d2a70b2ea in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#32 0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#33 0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#34 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#35 0x00000038009fd5de in gtk_widget_event_internal (widget=0x607000,
event=0x99b080) at gtkwidget.c:3732
#36 0x000000380089cf71 in IA__gtk_container_propagate_expose (container=Variable
"container" is not available.
) at gtkcontainer.c:2464
#37 0x00000038008687a0 in gtk_box_forall (container=0x5da040,
include_internals=Variable "include_internals" is not available.
) at gtkbox.c:703
#38 0x000000380089d9ce in gtk_container_expose (widget=0x5da040, event=0x7ba590)
at gtkcontainer.c:2375
#39 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa2bb20, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#40 0x0000003d2a70b2ea in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#41 0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#42 0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#43 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#44 0x00000038009fd5de in gtk_widget_event_internal (widget=0x5da040,
event=0x7ba590) at gtkwidget.c:3732
#45 0x000000380089cf71 in IA__gtk_container_propagate_expose (container=Variable
"container" is not available.
) at gtkcontainer.c:2464
#46 0x000000380089d9ce in gtk_container_expose (widget=0x5ba0a0,
event=0x7fffffa2c6d0) at gtkcontainer.c:2375
#47 0x0000003800923c7d in _gtk_marshal_BOOLEAN__BOXED (closure=0x5ad0e0,
return_value=0x7fffffa2c1d0, n_param_values=Variable "n_param_values" is not
available.
) at gtkmarshalers.c:83
#48 0x0000003d2a70b21d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#49 0x0000003d2a71b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#50 0x0000003d2a71c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#51 0x0000003d2a71c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#52 0x00000038009fd5de in gtk_widget_event_internal (widget=0x5ba0a0,
event=0x7fffffa2c6d0) at gtkwidget.c:3732
---Type <return> to continue, or q <return> to quit---
#53 0x000000380091eb00 in IA__gtk_main_do_event (event=0x7fffffa2c6d0) at
gtkmain.c:1380
#54 0x000000380063257a in gdk_window_process_updates_internal (window=0x5955b0)
at gdkwindow.c:2292
#55 0x000000380063270b in IA__gdk_window_process_all_updates () at gdkwindow.c:2345
#56 0x000000380063277a in gdk_window_update_idle (data=Variable "data" is not
available.
) at gdkwindow.c:2213
#57 0x0000003d2a526f7a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#58 0x0000003d2a52a105 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#59 0x0000003d2a52a42d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#60 0x000000380091ece3 in IA__gtk_main () at gtkmain.c:1001
#61 0x0000000000435dab in main ()
Comment 1 Brian Pepple 2006-03-12 10:06:31 EST
What rendering widget was used? We know of repeated crashes
when using GtkHTML2, which do not happen when using Mozilla.
Comment 2 Scott Tsai 2006-03-12 13:43:17 EST
I was using gtkhtml2-2.6.3-1.2.1
Should mozilla be configured as the default for future liferea packages then? Or
would that make it necessary to update liferea each time a mozilla security
update comes out for binary compatibility?
Comment 3 Michael Schwendt 2006-04-06 07:09:23 EDT
The dependency on Mozilla is a non-versioned one currently, so it could
break any time Mozilla breaks the interface. However, what's worse
than that is that installing liferea needs the full "mozilla" package
since there are not separate smaller mozilla packages to carry these
libraries.
Comment 4 Brian Pepple 2007-05-06 15:30:55 EDT
(In reply to comment #2)
> I was using gtkhtml2-2.6.3-1.2.1
> Should mozilla be configured as the default for future liferea packages then? Or
> would that make it necessary to update liferea each time a mozilla security
> update comes out for binary compatibility?

Closing this bug, since the gtkhtml2 plugin is disabled by upstream on x86_64.

Note You need to log in before you can comment on or make changes to this bug.