Bug 185218 - dhcpd ignores hardware address.
dhcpd ignores hardware address.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-11 19:15 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 17:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-03-11 19:15:47 EST
if I add a host to my network that doesn't have an entry in dhcpd.conf, it seems
to give away the first available ip it finds.

eg.. I have this in my config..

host wap-internal {
  hardware ethernet 00:0f:b5:14:81:d2;
  fixed-address 192.168.42.3;
  option host-name "wap-internal";
}

this is the ip of my wireless router, which was turned off.

I plugged in a new box, and dhcpd did this..

Mar 11 19:15:24 firewall dhcpd: DHCPDISCOVER from 00:a0:cc:59:ea:f6 via eth1
Mar 11 19:15:25 firewall dhcpd: DHCPOFFER on 192.168.42.3 to 00:a0:cc:59:ea:f6
via eth1
Mar 11 19:15:25 firewall dhcpd: DHCPREQUEST for 192.168.42.3 (192.168.42.1) from
00:a0:cc:59:ea:f6 via eth1
Mar 11 19:15:25 firewall dhcpd: DHCPACK on 192.168.42.3 to 00:a0:cc:59:ea:f6 via
eth1

the hardware address obviously doesn't match, so why did it get this lease ?

shouldn't correct behaviour be 'you dont get a lease until you have an entry in
dhcpd.conf' ?
Comment 1 Jason Vas Dias 2006-03-12 14:21:24 EST
RE: > shouldn't correct behaviour be 'you dont get a lease until you have an 
    > entry in dhcpd.conf' ?

Not if there is no active lease for an IP that is in a dynamic lease pool.

What are your dhcpd.conf 'subnet{ ... range...; }' statements ?

Presumably you have some kind of 'range xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx;' 
statement in your 'subnet ...{...}' declaration and 192.168.42.3 is in 
that range.

Since there is no active lease for 192.168.42.3 (the router is switched off),
then the server will allocate the first free lease, which turns out to be 
192.168.42.3.

If you want to disable this behaviour, then remove the 'range ...;' statements 
completely (then all clients MUST have a static lease 'host...{fixed-address..}'
declaration in dhcpd.conf in order to obtain a lease) or make your dynamic lease
pool range statements exclude your static lease declarations:
 'subnet 192.168.42.0 {... range 192.168.42.1 192.168.42.2;
                           range 192.168.42.4 192.168.42.254; ...
                      }
 '

I think this is intended dhcpd behaviour: ie. all free leases in dynamic
'range...;' pools are subject to allocation, even if free static leases overlap.
                   
Comment 2 Jason Vas Dias 2006-04-20 17:06:15 EDT
In the absence of the further information requested, this is being closed as
'NOTABUG'. 

If you have a 'range' statement in dhcpd.conf that covers the static leases
also, this is NOTABUG - it is intended behaviour of the dhcp server, as 
documented here:
http://marc.theaimsgroup.com/?t=114542355000001&r=1&w=2

If you do not have a range statement that covers your static leases, and the
problem still happens, then please re-open the bug, supplying the dhcpd.conf
you use . I've been unable to reproduce the problem without a conflicting
range .

Note You need to log in before you can comment on or make changes to this bug.