Bug 185229 - Unable to install on AMD64 with MPT SCSI controller and > 2GB memory
Unable to install on AMD64 with MPT SCSI controller and > 2GB memory
Status: CLOSED DUPLICATE of bug 191039
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-12 03:22 EST by Thomas Cameron
Modified: 2013-08-05 21:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 19:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport from FC5 box with mem=3490M (598.93 KB, application/x-bzip)
2006-04-18 20:48 EDT, Thomas Cameron
no flags Details
RHEL 4 AS U3 x86_64 SysReport (475.18 KB, application/x-bzip)
2006-04-19 08:03 EDT, Thomas Cameron
no flags Details

  None (edit)
Description Thomas Cameron 2006-03-12 03:22:48 EST
Description of problem:

System Config follows:

Motherboard:
 - Abit KN8-SLI board
Processor:
 - AMD X2 dual-core Athlon 64 4600+
SCSI Card:
 - LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)

I've installed RHEL 4 U2 on this system when it only had 2GB on it.  No problems
at all.  Upgraded to 4GB memory and first I got an error about "high address but
no iommu."  Got around that by passing iommu=soft to the kernel.

Next problem is that the SCSI controller kernel module seems to fail with an
error "mptbase: Initiating ioc0 recovery" over and over.

Booting with only 2GB of memory seems to make it work just fine.

Version-Release number of selected component (if applicable):
I am using the RHEL 4 U2 boot.iso image burned to CD to do an installation.

How reproducible:
Boot with > 2GB memory on the above hardware configuration.

Steps to Reproduce:
1.  Boot with > 2GB memory on the above hardware configuration.
2.
3.
  
Actual results:
"mptbase: Initiating ioc0 recovery" over and over.

Expected results:
Successful installation

Additional info:
Comment 1 Thomas Cameron 2006-03-19 00:20:13 EST
Sorry, I did dome more experiments and it seems that up to but not including 4GB
of memory works.  It is when the system tries to address 4GB or more.

I did a boot with mem=4000M and it seems to have cleared the problem up.  If I
boot with mem=4096 I see the issue again.

This is a real pain since booting with mem=4000 results in only 3469036 kB
memory recognized (cat /proc/meminfo).

Help?
Comment 2 Thomas Cameron 2006-04-18 12:47:23 EDT
Additional info - the same issue is present with FC5 on this system.  If I don't
choke memory by using mem=4000M at boot time the system doesn't boot.
Comment 3 Jim Paradis 2006-04-18 12:57:09 EDT
Can you get a serial console capture of a failed boot session and attach it to
this report?
Comment 4 Thomas Cameron 2006-04-18 16:41:23 EDT
I will go get a null-modem cable now, and will have serial console set up in an
hour or two.  Back soon with details.
Comment 5 Thomas Cameron 2006-04-18 17:09:21 EDT
Well, never mind.  This is a KN8-SLI motherboard.  No serial ports at all.  Just
USB.  Thoughts?
Comment 6 Jim Paradis 2006-04-18 17:40:16 EDT
Try booting with 4000M, then do a sysreport and attach the result.
Comment 7 Thomas Cameron 2006-04-18 20:48:21 EDT
Created attachment 127959 [details]
sysreport from FC5 box with mem=3490M

This is FC5.  I will reload with RHEL 4 U3 and upload that sysreport in a
while.
Comment 8 Thomas Cameron 2006-04-19 08:03:10 EDT
Created attachment 127981 [details]
RHEL 4 AS U3 x86_64 SysReport

RHEL 4 AS U3 x86_64 SysReport
Comment 9 Thomas Cameron 2006-04-19 08:10:09 EDT
FYI - I bought a USB to serial adapter and null modem cable, but passing
console=ttyUSB0,9600 to the kernel at boot time did not work.  The USB adapter
only worked after the system was up and had populated /dev.  Sorry.
Comment 10 soul916 2006-05-31 04:54:18 EDT
I encounter the same situation when I want to install RHEL4U3 into IBM e325 server
This server have 4G mem two AMD 248 CPU and LSI 53c1030 PCI-X Fusion-MPT Dual
Ultra320 SCSI Card
Comment 11 soul916 2006-06-05 02:16:02 EDT
I use IBM e325 server with 4G mem and LSI 53c1030 PCI-X Fusion-MPT Dual
Ultra320 SCSI Card.
I use two SCSI disks config as RAID1 in 53c1030
After some test I found the mem=2000M did't make my e325 installation startup 
with same error.
I found if I recompile the kernel linux-2.6.9-34.0.1 whith out PCI_MSI option 
the kernel will startup successful.
Comment 12 Jim Paradis 2006-09-28 19:27:27 EDT
This issue looks like a duplicate of Bug 191039, which has been fixed in the
latest update.  Please try the most recent RHEL4 kernel and verify that this is
fixed.

*** This bug has been marked as a duplicate of 191039 ***

Note You need to log in before you can comment on or make changes to this bug.