Bug 18526 - Can't package on earlier RH release
Summary: Can't package on earlier RH release
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 14:02 UTC by kenneth_porter
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 13:40:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for spec file (819 bytes, patch)
2000-10-06 14:04 UTC, kenneth_porter
no flags Details | Diff

Description kenneth_porter 2000-10-06 14:02:47 UTC
On earlier releases of Red Hat Linux, man pages were placed in /usr/man, not /usr/share/man. This is reflected in the %{manpath} macro. The 
dhcp Makefiles are configured to place man pages in /usr/share/man, but the spec file %file section places them in %{manpath}. This is easily 
fixed by changing the spec file's install command to be:

make install DESTDIR=%{buildroot} ADMMANDIR=%{_mandir}/man8 FFMANDIR=%{_mandir}/man5

I will be attaching a context diff for patching the spec file.

Comment 1 kenneth_porter 2000-10-06 14:04:09 UTC
Created attachment 3838 [details]
Patch for spec file

Comment 2 Elliot Lee 2001-07-20 04:42:10 UTC
This bug has long since been fixed.

Apologies for unresponsiveness of previous dhcp packager...


Note You need to log in before you can comment on or make changes to this bug.