Bug 185353 - anaconda does not install bootable system (dmraid, dell p470)
anaconda does not install bootable system (dmraid, dell p470)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 17:45 EST by Bill Nottingham
Modified: 2014-03-16 22:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 08:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-03-13 17:45:19 EST
Description of problem:

Dell Precision 470 workstation. Has BIOS RAID, intel chipset.

If you enable and create a RAID in the BIOS, dmraid/anaconda does not
see it, and offers to install on the drives themselves.

This configuration *does not boot*. First, grub halts at:

GRUB

If you reboot to rescue mode and run grub-install, it will
then die at:

GRUB loading, please wait.... Error 2

Oh, if you then 'delete' the RAID in the BIOS, you then get to reinstall. :/
Comment 1 Peter Jones 2006-03-14 02:11:06 EST
OK, so this sounds like grub was installed on hda, not on the raid device, but
the BIOS is using the raid device.

From IRC:
<notting> dmraid -ay always said 'no raid found'
<pjones> well, that'd be why it didn't work
<pjones> what bios?
<notting> bios or controller type?
<pjones> controller type
<notting> ich5

So I think that means we're not detecting ich5 correctly.

Metadata dumps from dmraid with the "isw" format would be helpful, but this is a
dmraid problem not an installer problem, so I'm reassigning it to that component.
Comment 2 Heinz Mauelshagen 2006-03-14 10:56:05 EST
Ich5 not supported yet.
Don't have access to respective metadata format specs.
If anyone has, please send them.
Comment 3 Bill Nottingham 2006-03-14 13:27:52 EST
I asked Dell, they said it should be DDF.
Comment 4 Heinz Mauelshagen 2007-06-27 08:04:52 EDT
Closing because there's no evidence, that the issue reapeared since we support DDF.

Note You need to log in before you can comment on or make changes to this bug.