Bug 185421 - pkg-config --list-all fails due to xfont.pc needing fontenc.pc
pkg-config --list-all fails due to xfont.pc needing fontenc.pc
Status: CLOSED DUPLICATE of bug 185778
Product: Fedora
Classification: Fedora
Component: libXfont (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 12:06 EST by Nick Lamb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 23:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Lamb 2006-03-14 12:06:33 EST
Description of problem:

pkg-config --list-all fails with the error:
Package fontenc was not found in the pkg-config search path.

It turns out, with debugging enabled, that this occurs because the package
'libXfont-devel' installs a pkg-config xfont.pc file which includes the line:
Requires.private: fontenc freetype2

Yet, libXfont-devel does not have a dependency on libfontenc-devel, and so this
cannot work.

So far as I can see, either (1) libXfont-devel needs a dependency on
libfontenc-devel OR (2) the pkg-config configuration xfont.pc should be edited
to remove this dependency from the build process.
Comment 1 Mike A. Harris 2006-03-16 01:17:30 EST
The Requires.private stuff is only used when static linking I believe, however
we only ship the dynamic libraries.  So, while Requires.private is still
relevent, it isn't used by anything in practice as far as I'm aware.

I'm more inclined to add an additional (and possibly unnecessary) dependency
on fontenc/freetype2 though than to patch the upstream *.pc files and keep
forked versions of them in our tree.

Comment 2 Mike A. Harris 2006-06-05 23:18:25 EDT

*** This bug has been marked as a duplicate of 185778 ***

Note You need to log in before you can comment on or make changes to this bug.