Bug 185430 - cman-kernel SRPM fails to build with "%define buildxen=1"
Summary: cman-kernel SRPM fails to build with "%define buildxen=1"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cman-kernel   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-14 19:22 UTC by Phillip Sorensen
Modified: 2008-02-26 23:00 UTC (History)
0 users

Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 23:00:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patched spec file (1.12 KB, patch)
2006-03-14 19:22 UTC, Phillip Sorensen
no flags Details | Diff

Description Phillip Sorensen 2006-03-14 19:22:25 UTC
Description of problem:

To try clustering and xen together I needed to rebuild the cman-kernel package
to get the kernel modules for xen0 and xenU kernels.  They are not currently
built (bugzilla #177772).

The rebuild faild with a missing Makefile in the kernel-devel tree.


Version-Release number of selected component (if applicable):
cman-kernel-2.6.15.1-0.FC5.13

How reproducible:
Always

Steps to Reproduce:
1. download and install cman-kernel-2.6.15.1-0.FC5.13.src.rpm
2. download and install xen0 and xenU kernel and kernel-devel packages
3. rpmbuild -bb --target=i686 cman-kernel.spec
  
Actual results:
Build fails

Expected results:
RPMS for up, smp, xen0, and xenU kernels

Additional Information:

It appears that this problem is caused by moving to the Xen kernel tree that
includes Xen as a variant type of i386 instead of a new ARCH.  When I removed
the ARCH=xen statments from the spec file everything build as expected.  I am
attaching the diff between my working spec and the original.  (The dependencies
also need updating is buildxen is enabled)

Comment 1 Phillip Sorensen 2006-03-14 19:22:25 UTC
Created attachment 126116 [details]
Patched spec file

Comment 2 Phillip Sorensen 2006-03-14 19:35:18 UTC
Just for peoples info, I also have filed bugzilla #185432 for the same problem
for dlm-kernel.  It may also apply to GFS-kernel and gnbd-kernel

Comment 3 Chris Feist 2006-03-22 23:16:50 UTC
Should be fixed in the cman-kernel which was released with FC5.


Note You need to log in before you can comment on or make changes to this bug.