Bug 185472 - KERNEL BUG AT MM/PRIO_TREE.C:527!
KERNEL BUG AT MM/PRIO_TREE.C:527!
Status: CLOSED DUPLICATE of bug 171778
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 18:44 EST by Greg Marsden
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 09:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Marsden 2006-03-14 18:44:22 EST
4-node cluster with oracle 10.2.0.1 with 10202 patchset.
RHEL4 U2.
.
While the workload is running, the kernel  paniced as below.
.
------------[ cut here ]------------
kernel BUG at mm/prio_tree.c:527!
invalid operand: 0000 [#1]
SMP
Modules linked in: nfsd exportfs md5 ipv6 parport_pc lp parport oracleasm(U)
netconsole netdump autofs4 i2c_dev i2c_core nfs lockd sunrpc dm_mirror
dm_multipath ohci_hcd cpqphp e100 e1000 eepro100 floppy ext3 jbd qla2xxx
scsi_transport_fc ccissEIP is at vma_prio_tree_add+0x10/0x95
eax: eabf80cc   ebx: eabf80cc   ecx: 00000000   edx: 000000f6
esi: eb8c6e8c   edi: b71a1000   ebp: f5ea1640   esp: eae24ee0
ds: 007b   es: 007b   ss: 0068
Process oracle (pid: 3226, threadinfo=eae24000 task=f4e974d0)
Stack: eafeb38c eb21b6fc eaa27420
      f7db684c f7db6830 00000000 b70f1000 eabf80cc eb21b6fc b70f1000
b71a1000
      c014f7da 00000146 eabf80cc f5ea1640 b70f1000 eb21b6fc b70a1000
f5ea1640
Call Trace:
[<c014e46e>] vma_adjust+0x166/0x2d6
[<c014f7da>] split_vma+0xa2/0xd2
[<c014f8e1>] do_munmap+0xd7/0x137
[<c014ebd5>] do_mmap_pgoff+0x311/0x666
[<c010b67f>] sys_mmap2+0x7e/0xaf
[<c02d10cf>] syscall_call+0x7/0xb
Code: ff ff 8d 4c 24 04 89 e2 89 d8 e8 fa fd ff ff 85 c0 74 d4 eb a2 8b 03 5a
59 5b c3 56 89 d6 8b 4e 4c 53 8b 50 4c 89 c3 39 ca 17 2b 54
Comment 1 Greg Marsden 2006-03-14 18:46:37 EST
*** WIRWIN  01/23/06 11:22 am ***
vma_adjust() is relatively complex, so it is a possible culprit, though
mm/prio_tree.c is the most likely culprit. Furthermore, mm/prio_tree.c seems
to have been updated a number of times in mainline and several bugs
postdating the RHEL4 U2 release were reported, but the changelog (such as
exists) is a little bit hairy to access. I'll check in later today with the
results of scrutinizing that. 
Comment 2 Greg Marsden 2006-03-14 18:47:30 EST
Another customer, SR 5177781.992 reports similar crash while upgrading 9.2 to
10.2, again on RHEL4
.
/var/etc/messages -->
.
Feb 22 19:03:37 evan kernel: ------------[ cut here ]------------
Feb 22 19:03:37 evan kernel: kernel BUG at mm/prio_tree.c:528!
Feb 22 19:03:37 evan kernel: invalid  operand: 0000 [#1]
Feb 22 19:03:37 evan kernel: SMP
Feb 22 19:03:37 evan kernel: Modules linked in: mptctl mptbase parport_pc lp
parport autofs4 i2c_dev i2c_core sunrpc dm_mirror dm_mod button battery ac
md5
ipv6 ohci_hcd tg3 floppy sg ext3 jbd aic7xxx sd_mod scsi_mod
Feb 22 19:03:37 evan kernel: CPU:    3
Feb 22 19:03:37 evan kernel: EIP:    0060:[<c01451a1>]    Not tainted VLI
Feb 22 19:03:37 evan kernel: EFLAGS: 00210202   (2.6.9-22.ELsmp)
Feb 22 19:03:37 evan kernel: EIP is at vma_prio_tree_add+0x36/0x95
Feb 22 19:03:37 evan kernel: eax: 00000047   ebx: f2eaeb1c   ecx: 00000000  
edx: 000001ef
Feb 22 19:03:37 evan kernel: esi: f5e0a22c   edi: b05ef000   ebp: f7582380  
esp:  c51f7ee0
Feb 22 19:03:37 evan kernel: ds: 007b   es: 007b   ss: 0068
Feb 22 19:03:37 evan kernel: Process oracle (pid: 30131, threadinfo=c51f7000
task=c7e4c630)
Feb 22 19:03:38 evan kernel: Stack: d6bd29bc f2eaeb1c c014e515  f60fdf20
00000000 00000000 d04d59fc f4bed880
Feb 22 19:03:38 evan kernel:        f6d1ef3c f6d1ef20 00000000 b03ff000
c93cf3e4 f2eaeb1c b05ef000 00000000
Feb  22 19:03:38 evan kernel:        c014f7fe 00000000 c93cf3e4 f7582380
b0a5f000 f2eaeb1c b05ef000 f7582380
Feb 22 19:03:38 evan kernel: Call Trace:
Feb 22 19:03:38 evan kernel:  [<c014e515>] vma_adjust+0x20d/0x2d6
Feb 22 19:03:38 evan kernel:  [<c014f7fe>] split_vma+0xc6/0xd2
Feb 22 19:03:38 evan kernel:  [<c014f8b0>] do_munmap+0xa6/0x137
Feb 22 19:03:38 evan kernel:  [<c014ebd5>] do_mmap_pgoff+0x311/0x666
Feb 22 19:03:38 evan kernel:  [<c010b67f>] sys_mmap2+0x7e/0xaf
Feb 22 19:03:38 evan kernel:  [<c02d10cf>] syscall_call+0x7/0xb
Feb 22 19:03:38 evan kernel:  [<c02d007b>] __lock_text_end+0x11a/0x100f
Feb 22 19:03:38 evan kernel: Code: c3 39 ca 74 08  0f 0b 0f 02 17 4d 2e c0 8b
43
08 2b 43 04 c1 e8 0c 8d 54 02 ff 8b 46 08 2b 46  04 c1 e8 0c 8d 44 01 ff 39
c2
74 08 <0f> 0b 10 02 17 4d 2e c0 c7 43 34 00 00 00 00 83 7e 34 00 c7 43
Feb 22 19:03:38 evan kernel:  <0>Fatal exception: panic in 5 seconds 
Comment 3 Jason Baron 2006-03-15 09:05:43 EST
well knownw U2 bug. fixed in U3.
Comment 4 Jason Baron 2006-03-15 09:06:44 EST

*** This bug has been marked as a duplicate of 171778 ***

Note You need to log in before you can comment on or make changes to this bug.