Bug 185487 - CP1251 is not working becoz of patch 157208
CP1251 is not working becoz of patch 157208
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 00:29 EST by Vasiliy Kotikov
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-04 09:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasiliy Kotikov 2006-03-15 00:29:30 EST
Description of problem:
Latest releases of samba with patch #20 - samba-3.0.10-bug157208, display of
cyrillic cp1251 is not working. Disabling this patch - ok.

Version-Release number of selected component (if applicable):
3.0.10-1.4E.6

How reproducible:
rpmbuild with and without patch #20 and create a file with cyrillic symbols
(example: ТЕСТОВЫЙ.txt) file, create share and mount Windows 2000(3) dir-share
from Linux

sudo mount -t smbfs -o 
username=root,password=***,iocharset=cp1251,codepage=cp866,rw //uni022/programs
/mnt/uni022 && ls /mnt/uni022/Apps/1C

Actual results:
1C ЏаҐ¤ЇаЁпвЁҐ 7.70.021 ५. 447
Expected results:
1C Предприятие 7.70.021 рел. 447
Additional info:
Any cases, just contact Thank You
Comment 1 Vasiliy Kotikov 2006-08-15 15:03:55 EDT
Hello!

Problems with ru_RU.cp1251 in samba-3.0.10-1.4E.9 still exists!!!

Comment 2 Vasiliy Kotikov 2006-08-15 15:36:48 EDT
Additional info:
Using putty with "Character set translation on received data" set to "Win1251
(Cyrillic)"

Mounting on RHEL4 Windows2003 share.

Locale is set to en_US

[root@uni018 ~]# mount -t smbfs -o
username=root,password=********,iocharset=cp1251,codepage=cp866
//uni022.mstuca.ru/Programs /mnt/smb && cp /mnt/smb/*.txt /data/ && umount /mnt/smb

[root@uni018 ~]# ls /data
INF.txt  ????????.txt  ????????.txt

Setting putty to use "Win1251 (Cyrillic)" cp1251
All envirement sucg as mc, texts in console are displayed ok

[root@uni018 ~]# export LC_ALL=ru_RU.CP1251
[root@uni018 ~]# ls -Al /data
итого 8
-rwxr-xr-x  1 root root   0 Авг 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 Авг 15 23:27 ‰Ќ€ЊЂЌ€….txt
-rwxr-xr-x  1 root root 263 Авг 15 22:58 ‚Ќ€ЊЂЌ€….txt
[root@uni018 ~]#


Setting putty to use CP866

[root@uni018 ~]# ls -Al /data
шЄюую 8
-rwxr-xr-x  1 root root   0 └ту 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 └ту 15 23:27 ЙНИМАНИЕ.txt
-rwxr-xr-x  1 root root 263 └ту 15 22:58 ВНИМАНИЕ.txt
[root@uni018 ~]#

Now names of files are read ok, but other data such as date's month (Авг), total
 8(итого 8) are displayed incorrectly.

maybe I've missed something and I should mount in another way??? But without
this patch encoding works fine...

Hope for response...
Comment 3 Simo Sorce 2007-05-03 13:43:44 EDT
Vasiliy,
it seem like you expect smbfs to translate from cp866 (used remotely) to cp1251
locally (or vice versa), I don't think smbfs can do that.

I think in this case you want to use cifs, cifs uses unicode on the wire and can
be asked to translate from unicode to a different locale locally.

Let me know if there is something I am missing here.
Comment 4 Vasiliy Kotikov 2007-05-04 01:46:29 EDT
Hello!

Thank You for cifs using suggestion.

I changed everything to use cifs and now it is fast and no problem with 
localities (cyr also). So for me, the problem is no more actual.
But from the point of smbfs system and correct display of cp1251... the patch 
causes this this problem. And smbfs could do before patch apply. Why... I do 
not know.

Thank You
Comment 5 Simo Sorce 2007-05-04 09:37:56 EDT
Thank you for your quick reply.
As smbfs is deprecated I am going to close this bug now.
If someone really need to use smbfs for some reason and also happen to have this
same problem then, eventually, we can repoen this bug.

Note You need to log in before you can comment on or make changes to this bug.