This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 185495 - Huge memory allocation (size 106430492) rejected
Huge memory allocation (size 106430492) rejected
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 02:57 EST by peter haak
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 06:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter haak 2006-03-15 02:57:35 EST
Description of problem:
after the update from kernel 2.6.9-22.0.1 to 2.6.9-34 on 2 machines
1 machines can not restart because the lvm can not map the drives
message simmelar to this
Huge memory allocation (size 106430492) rejected - metadata corruption?
  Out of memory.  Requested 106430492 bytes.
2 machine startet but if i do a vgscan i get this message:
  Reading all physical volumes.  This may take a while...
  Huge memory allocation (size 106430492) rejected - metadata corruption?
  Out of memory.  Requested 106430492 bytes.
  Couldn't allocate logical volume maps.
  Huge memory allocation (size 106430492) rejected - metadata corruption?
  Out of memory.  Requested 106430492 bytes.
  Couldn't allocate logical volume maps.

Version-Release number of selected component (if applicable):
2.6.9-34.ELsmp #1 SMP 
Red Hat Enterprise Linux ES release 4 (Nahant Update 3)
Kernel \r on an \m
lvm2-2.02.01-1.3.RHEL4

How reproducible:
update to kernel 2.6.9-34

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:i don't know if it a kernel issue or a lvm issue
Comment 1 peter haak 2006-03-15 06:51:11 EST
this error occurs if on the san that is connected to the machines are an old
entry from a formerly installation
after an format on this disks it runs

Note You need to log in before you can comment on or make changes to this bug.