Bug 185539 - Eclipse crashes with log file indicating that the problem lies in (java class?) org.eclipse.core.resources
Eclipse crashes with log file indicating that the problem lies in (java class...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 12:21 EST by Frederik Hertzum
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 10:54:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log file number 1 (25.68 KB, text/plain)
2006-03-15 12:21 EST, Frederik Hertzum
no flags Details
log file number 2 (25.68 KB, text/plain)
2006-03-15 12:22 EST, Frederik Hertzum
no flags Details
log file number 3 (25.70 KB, text/plain)
2006-03-15 12:24 EST, Frederik Hertzum
no flags Details
log file number 4 (25.70 KB, text/plain)
2006-03-15 12:25 EST, Frederik Hertzum
no flags Details
log file number 5 (25.68 KB, text/plain)
2006-03-15 12:27 EST, Frederik Hertzum
no flags Details

  None (edit)
Description Frederik Hertzum 2006-03-15 12:21:08 EST
Description of problem:
Eclipse crashes emidietly after splash screen has been completed.
A crash window indicates the following:
An error has occurred. See the log file
/home/clearer/.eclipse/org.eclipse.platform_3.1.2/configuration/1142443230188.log.

The log file indicates the following (seems like the key problem):
!ENTRY org.eclipse.osgi 2006-03-14 17:48:51.24
!MESSAGE An error occurred while automatically activating bundle
org.eclipse.core.resources (79).
!STACK 0

Entire log is included.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.2-1jpp_13fc

How reproducible:
Happens every time I start it up.

Steps to Reproduce:
Unknown. It is likely a problem with a package Eclipse is dependent on. I have
attempted to reinstall all the packages that have to do with Eclipse, but have
been unable to fix the problem.
  
Actual results:
Crashed Eclipse.

Expected results:
Working Eclipse.

Additional info:
I have included several log files - one for each of the time that eclipse
crashes. I suspect that only one is needed. diff indicates quite a lot of lines
are different, but that is likely just to be time stamps differing on each line.
To be sure, it's all included.
Comment 1 Frederik Hertzum 2006-03-15 12:21:08 EST
Created attachment 126155 [details]
log file number 1
Comment 2 Frederik Hertzum 2006-03-15 12:22:19 EST
Created attachment 126157 [details]
log file number 2
Comment 3 Frederik Hertzum 2006-03-15 12:24:08 EST
Created attachment 126158 [details]
log file number 3
Comment 4 Frederik Hertzum 2006-03-15 12:25:18 EST
Created attachment 126159 [details]
log file number 4
Comment 5 Frederik Hertzum 2006-03-15 12:27:07 EST
Created attachment 126160 [details]
log file number 5
Comment 6 Andrew Overholt 2006-03-15 12:48:20 EST
It looks like your workspace is un-writable:

Root exception:
java.lang.IllegalStateException: The platform metadata area could not be
written: /home/clearer/workspace/.metadata.  By default the platform writes its
content
under the current working directory when the platform is launched.  Use the
-data parameter to
specify a different content area for the platform.
Comment 7 Frederik Hertzum 2006-03-15 15:24:54 EST
Removing my workspace and recreating it manually removed the problem. Shouldn't
this be handled in a different way? Say by alerting the user directly that the
workspace is unwritable, or by prompting the user to create a new workspace (or
something similar)?
Comment 8 Andrew Overholt 2006-03-30 10:54:45 EST
(In reply to comment #7)
> Removing my workspace and recreating it manually removed the problem. Shouldn't
> this be handled in a different way? Say by alerting the user directly that the
> workspace is unwritable, or by prompting the user to create a new workspace (or
> something similar)?

Yeah, I agree that the error messages could be nicer.  Perhaps file upstream as
an enhancement request at bugs.eclipse.org?

Note You need to log in before you can comment on or make changes to this bug.