Bug 185554 - up2date '@ GNOME Desktop Environment' defaults to up2date -u and backgrounds itself
up2date '@ GNOME Desktop Environment' defaults to up2date -u and backgrounds ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks: 190430 191074 191079 234542
  Show dependency treegraph
 
Reported: 2006-03-15 14:13 EST by Beth Nackashi
Modified: 2013-02-26 19:49 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0439
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-03-15 14:13:43 EST
Description of problem:
Apparently there is not supposed to be a space between the '@' and the package
group name.  However if you put a space, up2date ignores the specific package
group requested and does up2date -u.

Once you realize this is happening, and you desperately try to ctrl-c out of
up2date, you find it has backgrounded itself and you have to kill it.

Version-Release number of selected component (if applicable):
whatever was shipped with rhel 3 u6 (I couldn't do rpm -a on up2date afterwards,
because up2date up2dated itself)

How reproducible:
always

Steps to Reproduce:
1.  Register a system to prod.
2.  Kickstart the system to rhel 3 u6.
3.  Log into the system and type:
            up2date '@ GNOME Desktop Environment'
  
Actual results:
defaults to up2date -u and backgrounds itself so ctrl-c won't kill it

Expected results:
if the space after '@' is unacceptable, give an error

Additional info:
Comment 1 Beth Nackashi 2006-03-15 14:31:43 EST
I meant, rpm -q, not rpm -a.
Comment 3 Fanny Augustin 2006-04-10 20:34:32 EDT
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release
Comment 4 Fanny Augustin 2006-04-13 15:39:23 EDT
Moving bugs to the CanFix List
Comment 5 Fanny Augustin 2006-05-08 15:18:57 EDT
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release
Comment 6 Fanny Augustin 2006-05-08 16:06:55 EDT
This bug did not make the code freeze.  It will not be fixed in this releasee 
Reea ligning to the next one.
Comment 10 Pradeep Kilambi 2006-09-25 16:02:58 EDT
do we really want to error of? because we can just strip of the whitespace at
the beginning and make it work similar.

This is how it would work:

when we run
$ up2date "@GNOME Desktop Environment"

we basically pass this args into splitGlobsAndComps(pkgNames)

which basically checks for if pkgName[0] == '@' if so parses the rest of the
name as comps. 

so in this case '@GNOME Desktop Environment' is parsed as:

['GNOME Desktop Environment'] [] []

now in second case we :

$ up2date "@ GNOME Desktop Environment"

it parses and calls the same splitGlobsAndComps(pkgNames) and not gets comps as
[' GNOME Desktop Environment'] [] []

now when we get this it basically compare this string in the available list and
it basically defaults to up2date -u.

now instead of allowing this we basically stirp of the whitespace so that "@
GNOME Desktop Environment" and "@GNOME Desktop Environment" result as the same..

as follows:

[pkilambi@prad up2date]$ svn diff
Index: wrapper.py
===================================================================
--- wrapper.py  (revision 102922)
+++ wrapper.py  (working copy)
@@ -981,7 +981,7 @@
     tmpPkgNames = []
     for token in pkgNames:
         if token[0] == '@':
-            comps.append(token[1:])
+            comps.append(token[1:].strip())
             continue

         if (string.find(token, '?') != -1) or (string.find(token, '*') != -1) or \

this results in same set of packages to be aligned for install.
Comment 11 Pradeep Kilambi 2007-01-04 15:15:17 EST
this has not been devel-ack'ed. reverting and moving it to new.
Comment 12 Pradeep Kilambi 2007-04-10 10:13:05 EDT
this is fixed for 4.5 and so is for 3.9, moving to modified
Comment 14 wes hayutin 2007-04-12 15:40:50 EDT
weshay weshay prad, question about
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185554
weshay weshay prad, should I only test 4.5 for now?
weshay prad weshay: I built a el3 version on up2date, you should be using that
to test 3.9 bugs
weshay prad weshay: i added that rpm to the errata and waived the diffs,  you
should be all set (I think)
cwelton http://porkchop.devel.redhat.com/brewroot/packages/up2date/
weshay http://porkchop.devel.redhat.com/brewroot/packages/up2date/4.5.5/5.el3/i386/
Comment 15 wes hayutin 2007-04-24 15:30:13 EDT
[root@dhcp231-70 root]# ls
anaconda-ks.cfg  install.log.syslog          up2date-4.5.5-5.el3.i386.rpm
install.log      rhnmd-5.0.0-1.el3.i386.rpm
[root@dhcp231-70 root]# rpm -Uvh up2date-4.5.5-5.el3.i386.rpm
Preparing...                ########################################### [100%]
        package up2date-4.5.5-5.el3 is already installed
[root@dhcp231-70 root]# rpm -ivh up2date-4.5.5-5.el3.i386.rpm
Preparing...                ########################################### [100%]
        package up2date-4.5.5-5.el3 is already installed
[root@dhcp231-70 root]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 9 Beta)
[root@dhcp231-70 root]#
Comment 16 wes hayutin 2007-04-24 15:31:29 EDT
[root@dhcp231-70 root]# rpm -Uvh up2date-4.5.5-5.el3.i386.rpm --force
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [100%
Comment 17 wes hayutin 2007-04-24 15:33:48 EDT
the installer never returns... :(
Comment 18 Pradeep Kilambi 2007-04-24 15:51:51 EDT
i think you misunderstood the intent of the bug, the bug should be tested for
package groups, not up2date itself.

something like: $ up2date '@ group'.

if your up2date install did not return, it could be due to multiple reasons like
corrupted rpm db etc..

try rm -rf /var/lib/rpm/__db* and retry.
Comment 19 wes hayutin 2007-04-24 16:31:39 EDT
Pradeep, sorry for the confusing notes.. but I was just trying to get your
updated rpm installed on my test machine (brand new install) to test up2date.. 
I couldnt get the rpm from porkchop to install.

Once that is installed.. then I understand to try the group options.. ie.. @
group etc..

Do you have a different copy of the rpm I can try?
Comment 20 Pradeep Kilambi 2007-04-25 10:19:54 EDT
oh no problem. The rpm probably is corrupted, I built a new version for you its
called up2date-4.5.5-6.el3 in brewroot, could you try this and let me know?

The new one is working for me, if you can confirm that i'll update the errata.

[root@test09-64 root]# rpm -Uvh
http://vault.rhndev.redhat.com/redhat/brewroot/packages/up2date/4.5.5/6.el3/x86_64/up2date-4.5.5-6.el3.x86_64.rpm
Retrieving
http://vault.rhndev.redhat.com/redhat/brewroot/packages/up2date/4.5.5/6.el3/x86_64/up2date-4.5.5-6.el3.x86_64.rpm
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [100%]
[root@test09-64 root]# 
Comment 21 wes hayutin 2007-04-25 14:05:07 EDT
it now installs and looks good
passing

[root@dhcp231-70 root]# up2date "@ GNOME Desktop Environment"
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
 
[root@dhcp231-70 root]# up2date " @ GNOME Desktop Environment"
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
 
 
The following packages you requested were not found:
 @ GNOME Desktop Environment
[root@dhcp231-70 root]# up2date '@ GNOME Desktop Environment'
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
 
[root@dhcp231-70 root]# up2date '@ GNOME'
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
 
[root@dhcp231-70 root]# up2date '@ GNO'
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
 
Name                                    Version        Rel
----------------------------------------------------------
 
The following groups did not match any packages:
GNO
[root@dhcp231-70 root]# up2date '@ KDE'
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
autorun                                 3.10           1                 i386
htdig                                   3.1.6          3                 i386
kdeaddons                               3.1.3          1                 i386
kdeartwork                              3.1.3          1.1               i386
kdegraphics                             3.1.3          3.10              i386
kdenetwork                              3.1.3          1.8               i386
kdeutils                                3.1.3          3.1               i386
switchdesk-kde                          3.9.8          17                i386
 
 
Testing package set / solving RPM inter-dependencies...
 
 
[root@dhcp231-70 root]#
[root@dhcp231-70 root]#
[root@dhcp231-70 root]# up2date '@   KDE'
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
autorun                                 3.10           1                 i386
htdig                                   3.1.6          3                 i386
kdeaddons                               3.1.3          1                 i386
kdeartwork                              3.1.3          1.1               i386
kdegraphics                             3.1.3          3.10              i386
kdenetwork                              3.1.3          1.8               i386
kdeutils                                3.1.3          3.1               i386
switchdesk-kde                          3.9.8          17                i386
 
 
Testing package set / solving RPM inter-dependencies...
[root@dhcp231-70 root]#
[root@dhcp231-70 root]# up2date '@   KDE   '
 
Fetching Obsoletes list for channel: rhel-i386-as-3...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
autorun                                 3.10           1                 i386
htdig                                   3.1.6          3                 i386
kdeaddons                               3.1.3          1                 i386
kdeartwork                              3.1.3          1.1               i386
kdegraphics                             3.1.3          3.10              i386
kdenetwork                              3.1.3          1.8               i386
kdeutils                                3.1.3          3.1               i386
switchdesk-kde                          3.9.8          17                i386
 
 
Testing package set / solving RPM inter-dependencies...
Comment 23 Red Hat Bugzilla 2007-06-11 14:46:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0439.html

Note You need to log in before you can comment on or make changes to this bug.