Bug 185567 - traceback while using firstboot -- then cannot register username
traceback while using firstboot -- then cannot register username
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: firstboot (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks: 179652
  Show dependency treegraph
 
Reported: 2006-03-15 16:12 EST by Beth Nackashi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 08:56:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-03-15 16:12:57 EST
Description of problem:
Firstboot spits out a 'NoneType' object traceback.

Version-Release number of selected component (if applicable):
firstboot-1.1.33-1
up2date-4.4.67-3


How reproducible:
always

Steps to Reproduce:
1.  Install a system with rhel 3 u6.  Register it to prod.
2.  up2date firstboot
3.  up2date '@GNOME Desktop Environment'
4.  Edit /etc/sysconfig/firstboot -- change to 'RUN_FIRSTBOOT=YES'
5.  Edit /usr/share/firstboot/firstboot.py -- change to 'if runlevel == 1'
6.  Log out of system.
7.  Log back in using ssh -Y.
8.  Remove /etc/sysconfig/rhn/systemid*
9.  Run firstboot --forcegui --debug &
10. Red Hat Login -> populate the Login and Password fields -> Click on Network
Configuration -> populate server field with 'https://rlx-2-14.rhndev.redhat.com'
-> Click OK -> Click Next
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 278, in nextClicked
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/rhn_login_gui.py", line 165, in apply
    ret = self.loginPageApply()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 155, in loginPageApply
    self.getCaps()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 97, in getCaps
    caps = rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 213, in getCaps
    s = rpcServer.getServer()
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 192, in getServer
    password=proxyPassword)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 149, in __init__
    type = string.lower(type)
  File "/usr/src/build/513931-i386/install/usr/lib/python2.2/string.py", line
54, in lower
    return s.lower()
AttributeError: 'NoneType' object has no attribute 'lower'


Since there is a problem with the Red Hat Login module, 
Red Hat Setup Agent will not load this module and 
will attempt to run the remaining modules.

Please file a bug against 'firstboot' in the Red Hat 
bug tracking system at http://www.redhat.com/bugzilla. 
A copy of the debug output has been saved to /root/firstboot.1142452444.92 
Be sure to attach that file to the bug report. 


Expected results:
no traceback

Additional info:

Note You need to log in before you can comment on or make changes to this bug.