This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 185578 - powernow-k8 wont load on all SMP systems
powernow-k8 wont load on all SMP systems
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 17:36 EST by Brian Maly
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 16:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Maly 2006-03-15 17:36:26 EST
Description of problem: Powernow driver only loads on SMP systems if p-states
table exists in BIOS for all CPU's. Most vendors dont include this in their BIOS
so most AMD based systems cant use SMP powernow

Version-Release number of selected component (if applicable):


How reproducible: boot system or insmod powernow-k8 on an AMD dual processor or
dual core system and see if the powernow-k8 module loads correctly


Steps to Reproduce:
1. load powernow-k8 on AMD64 based system (SMP)
2. 
3.
  
Actual results:
driver will not load on some systems (error about MP table issues)

Expected results:
driver should load on all systems

Additional info:

plan is to add a boot arg as a workaround that makes the powernow-k8 driver use
the power state table from the first processor (and use it for all processors)
if BIOS doesnt have power state tables for all CPU's
Comment 1 Marc Jadoul 2006-04-04 07:33:08 EDT
Please tell me when I can test this or what I can do to help.

I have an ACER G5350 with only one (1 of 2) dual core Opteron 270. It is
currently running Fedora Core 4 with latest kernel.
Effectively powernow does not work. I would have expected that, given the system
is certified for redhat, it would have been compatible with powernow.
I suspect that the problem is not necessarily in the Bios but with what the
kernel expect of the Bios. Is the kernel powernow code compatible with SMP
server that contain only one dual core processor?

Here is the message of the kernel:
powernow-k8: Found 2 AMD Athlon 64 / Opteron processors (version 1.60.0)
cpufreq-core: trying to register driver powernow-k8
cpufreq-core: adding CPU 0
powernow-k8: register performance failed: bad ACPI data
powernow-k8: MP systems not supported by PSB BIOS structure
cpufreq-core: initialization failed
cpufreq-core: adding CPU 1
powernow-k8: register performance failed: bad ACPI data
powernow-k8: MP systems not supported by PSB BIOS structure
cpufreq-core: initialization failed
cpufreq-core: no CPU initialized for driver powernow-k8
cpufreq-core: unregistering CPU 0
cpufreq-core: unregistering CPU 1
Comment 2 Marc Jadoul 2006-04-04 07:42:32 EDT
By the way: should give more priorityu to this: let's save the planet: my system
is used 6KWh in only 43 hours.
I tried to decompile the BIOS to see what is in it. But obviously it is above my
level of competence :-/
Comment 3 Brian Maly 2006-04-04 10:46:54 EDT
Marc, you are correct. Your vendors BIOS does not appear to support SMP
Powernow. When a fix is ready we would be happy if you would give it a test.

PS you can use acpidump to look at the power state tables in ACPI
Comment 4 Brian Maly 2006-04-04 11:03:15 EDT
also, powernow should support all SMP systems (dual core and multi-processor) if
the power state tables for all procs happen to be in BIOS. multi-core support
was added to RHEL4 as of U3.
Comment 5 Brian Maly 2007-08-30 16:06:38 EDT
AMD does not want this fixed. They would prefer that vendors update their BIOS
instead to support powernow properly.
Comment 6 Marc Jadoul 2007-09-01 04:54:09 EDT
* AMD SHOULD then obtain that ACER (the vendor) support this feature,
* Redhat SHOULD take this into account before certifying a server configuration.

Note You need to log in before you can comment on or make changes to this bug.