Bug 185592 - netdump LOCALPORT option not passed for 2.6 kernels
netdump LOCALPORT option not passed for 2.6 kernels
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: netdump (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-03-15 18:55 EST by Kevin W. Rudd
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0191
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin W. Rudd 2006-03-15 18:55:38 EST
Description of problem:

The netdump LOCALPORT value is not being passed to the netdump module for 2.6
kernels.  This creates a problem for systems that are configured as both a
netdump server and client as they both default to port 6666 (the default
localport of 6667 seems like a better approach to allow a netdump server to
point to a back-up server in order to save it's own panic information)

Version-Release number of selected component (if applicable):

netdump-0.7.14-4

How reproducible: Easy

Simply configure both netdump and netdump-server on a system.  External clients
trying to dump to this system will fail to handshake because the client code has
beaten the server to the 6666 port.  Setting the LOCALPORT variable in
/etc/sysconfig/netdump will have no effect as the netdump module is not being
passed the value.

Additional info:

The following diff illustrates the change needed to the /etc/init.d/netdump script:

# diff -au netdump.orig netdump
--- netdump.orig        2006-03-15 09:05:30.000000000 -0800
+++ netdump     2006-03-15 09:05:55.000000000 -0800
@@ -254,7 +254,7 @@
            $TGTMAC $MHZ $IDLETIMEOUT"
        else
            NETDUMPOPTS=$NETDUMPOPTS"\
-           netdump=@$LOCALADDR/$DEV,$NETDUMPPORT@$IPADDR/$NETDUMPMACADDR"
+           netdump=$LOCALPORT@$LOCALADDR/$DEV,$NETDUMPPORT@$IPADDR/$NETDUMPMACADDR"
        fi
     else
        # The netdump subsystem of the netconsole module is not configured.

I would also like to see the script changed so that the default for LOCALPORT is
something other than 6666 to avoid confusion for the customers that try to set
up both the client and server.
Comment 1 Neil Horman 2006-06-21 15:44:36 EDT
Thanks, I've checked this in.  I'll file an errata when U5 opens.
Comment 3 Daniel Riek 2006-08-27 22:51:42 EDT
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this enhancement by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This enhancement is not yet committed for inclusion in an Update release. 
Comment 12 Red Hat Bugzilla 2007-05-01 18:51:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0191.html

Note You need to log in before you can comment on or make changes to this bug.