Bug 185612 - Frysk does not run
Frysk does not run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: frysk (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Cagney
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-16 06:38 EST by Matthew Booth
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 12:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of failing frysk invocation (62.05 KB, application/x-bzip2)
2006-03-16 11:48 EST, Matthew Booth
no flags Details

  None (edit)
Description Matthew Booth 2006-03-16 06:38:32 EST
Description of problem:
Executing 'frysk' gives the following error, followed by immediate termination:

[mbooth@mbooth ~]$ frysk
Exception in thread "main" java.lang.ExceptionInInitializerError
   at _ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE
(/usr/lib/libgcj.so.6)
   at _ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6)
   at _ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6)
   at _ZN4java4lang5ErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6)
   at _ZN4java4lang12LinkageErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6)
   at _ZN4java4lang27ExceptionInInitializerErrorC1EPNS0_9ThrowableE
(/usr/lib/libgcj.so.6)
   at _ZN4java4lang5Class15initializeClassEv (/usr/lib/libgcj.so.6)
   at _Jv_InitClass (/usr/lib/libgcj.so.6)
   at 0x080da8cc (Unknown Source)
   at 0x080ccc44 (Unknown Source)
   at 0x080caa8e (Unknown Source)
   at 0x080c0244 (Unknown Source)
   at 0x080bb53c (Unknown Source)
   at 0x080bbc19 (Unknown Source)
   at 0x080bae4e (Unknown Source)
   at _ZN3gnu4java4lang10MainThread9call_mainEv (/usr/lib/libgcj.so.6)
   at _ZN3gnu4java4lang10MainThread3runEv (/usr/lib/libgcj.so.6)
   at _Z13_Jv_ThreadRunPN4java4lang6ThreadE (/usr/lib/libgcj.so.6)
   at _Z11_Jv_RunMainP14_Jv_VMInitArgsPN4java4lang5ClassEPKciPS6_b
(/usr/lib/libgcj.so.6)
   at _Z11_Jv_RunMainPN4java4lang5ClassEPKciPS4_b (/usr/lib/libgcj.so.6)
   at JvRunMain (/usr/lib/libgcj.so.6)
   at 0x080babf8 (Unknown Source)
   at __libc_start_main (/lib/tls/libc.so.6)
   at 0x080bab3d (Unknown Source)
Caused by: java.lang.NullPointerException
   at _ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE
(/usr/lib/libgcj.so.6)
   at _ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6)
   at _ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6)
   at _ZN4java4lang9ThrowableC1Ev (/usr/lib/libgcj.so.6)
   at _ZN4java4lang9ExceptionC1Ev (/usr/lib/libgcj.so.6)
   at _ZN4java4lang16RuntimeExceptionC1Ev (/usr/lib/libgcj.so.6)
   at _ZN4java4lang20NullPointerExceptionC1Ev (/usr/lib/libgcj.so.6)
   at 0x026f54cb (Unknown Source)
   at 0x026f41a8 (Unknown Source)
   at _ZN4java4lang5Class7getNameEv (/usr/lib/libgcj.so.6)
   at _ZN4java4util7logging6Logger19getCallerStackFrameEv (/usr/lib/libgcj.so.6)
  at _ZN4java4util7logging6Logger3logEPNS1_5LevelEPNS_4lang6StringEPNS5_6ObjectE
(/usr/lib/libgcj.so.6)
   at 0x080f3914 (Unknown Source)
   at 0x080eb8b0 (Unknown Source)
   ...18 more

Version-Release number of selected component (if applicable):

frysk-0.0.1.2006.02.19.rh1-0.EL4.1.i386

How reproducible:

Always

Steps to Reproduce:
1. On my RHEL4 U3 box, install frysk with 'up2date frysk'
2. type 'frysk'
Comment 1 Phil Muldoon 2006-03-16 11:39:14 EST
Hi Matthew

I can't produce this locally. One of the things we are doing is creating a
scratch install to try and reproduce. However, what would be useful in the
meantime is an strace of frysk, so we can look at the Frysk I/O. Something like 

strace frysk >& frysk_strace.log

And add that log as an attachment.



Phil
Comment 2 Matthew Booth 2006-03-16 11:48:33 EST
Created attachment 126231 [details]
strace of failing frysk invocation

Created as follows:

[mbooth@mbooth ~]$ strace -o frysk.strace frysk
Exception in thread "main" java.lang.ExceptionInInitializerError
   at _ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE
(/usr/lib/libgcj.so.6)
Comment 3 Phil Muldoon 2006-03-16 14:05:40 EST
Hi

Thanks for the trace. Can your print out what:

rpm -q libgcj4

and 

rpm -q gcc4 

print to the console?
Comment 4 Matthew Booth 2006-03-17 03:54:13 EST
[mbooth@mbooth ~]$ rpm -q libgcj4
package libgcj4 is not installed
[mbooth@mbooth ~]$ rpm -q gcc4
package gcc4 is not installed

I installed these 2 packages, and frysk now runs.
Comment 5 Phil Muldoon 2006-03-17 07:40:40 EST
Well that is good news. Still we have to figure out how Frysk got on the that
machine withoout the prerequisite RPM (turns out you don't need GCC4, just libgcj4).

We installed a machine with RHEL4-U3 from the scatch from a fresh format. I
installed the Frysk RPM from up2date and it did install libgcj4. Ouput as follows:

-bash-3.00$ sudo su
[root@towns pmuldoon]# DISPLAY= up2date frysk

Fetching Obsoletes list for channel: rhel-i386-as-4...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
frysk                                   0.0.1.2006.02.19.rh10.EL4.1
i386


Testing package set / solving RPM inter-dependencies...
########################################
frysk-0.0.1.2006.02.19.rh1- ########################## Done.
libgcj4-4.0.2-14.EL4.i386.r ########################## Done.
Preparing              ###########################################
[100%]

Installing...
   1:libgcj4                ###########################################
[100%]
   2:frysk                  ###########################################
[100%]
The following packages were added to your selection to satisfy
dependencies:

Name                                    Version        Release
--------------------------------------------------------------
libgcj4                                 4.0.2          14.EL4


So two quick questions then:

Was your machine an upgrade from an older version? 

Did you select Frysk from the anaconda package selection?

Comment 6 Andrew Cagney 2006-11-30 12:41:40 EST
Installing frysk on a 4.4. machine pulls in libgcj and then works.

Note You need to log in before you can comment on or make changes to this bug.