Bug 185645 - psmerge does not work at all
psmerge does not work at all
Product: Fedora
Classification: Fedora
Component: psutils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Depends On:
  Show dependency treegraph
Reported: 2006-03-16 12:20 EST by Peter Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.17-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-14 03:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
A better psmerge implementation that sometimes works (1.80 KB, text/plain)
2006-03-16 12:20 EST, Peter Williams
no flags Details

  None (edit)
Description Peter Williams 2006-03-16 12:20:58 EST
Created attachment 126232 [details]
A better psmerge implementation that sometimes works
Comment 1 Peter Williams 2006-03-16 12:20:58 EST
The psmerge program included with psutils simply doesn't work. Reading the
source will confirm that quickly. Note, for instance, that a line is only
printed of $print is set, and that variable occurs nowhere else in the program ...

I'm filing this bug with Red Hat because there doesn't seem to have been an
upstream release for nine years, so I doubt that the original author is going to
push a release for this fix -- if he can even be contacted. I'm not planning on
filing this bug with every distribution under the sun, but I'm not sure what
else to do about it besides get distros to fix it. (I'm not really interested in
claiming maintainership of the module or anything.)

I attach a version of psmerge that works for me, although I know nothing about
PostScript, so it may be fairly broken.
Comment 2 Jitka Kozana 2006-03-21 03:17:19 EST
Tried with psutils-1.17-25.  
Neither the original, neither yours implementation works for me (tried with ps   
files generated from .tex files). Your implementation added to the output file 
only the first ps file, the rest of the file was blank (however, the number of 
pages in the output was ok). 
Comment 3 Jitka Kozana 2006-06-14 03:09:19 EDT
This implementation is now included in the latest version of psutils, which is

Note You need to log in before you can comment on or make changes to this bug.