Bug 185681 - Lots of new pam_krb5 syslog messages after update
Lots of new pam_krb5 syslog messages after update
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vixie-cron (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2006-03-16 16:08 EST by Marc Desrochers
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0301
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 14:59:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Desrochers 2006-03-16 16:08:12 EST
Description of problem:
Upgraded to RPMs for RH EL3 Update 7 and /var/log/cron is now filling
up with messages, e.g. :

Mar 16 16:00:01 attila crond[22238]: PAM unable to dlopen(/lib/security/pam_krb5.so)
Mar 16 16:00:01 attila crond[22238]: PAM [dlerror: /lib/security/pam_krb5.so:
cannot open shared object file: No such file or directory]
Mar 16 16:00:01 attila crond[22238]: PAM adding faulty module:
/lib/security/pam_krb5.so
Mar 16 16:00:01 attila crond[22239]: (root) CMD (/usr/lib/sa/sa1 1 1)
Mar 16 16:01:01 attila crond[22289]: PAM unable to dlopen(/lib/security/pam_krb5.so)
Mar 16 16:01:01 attila crond[22289]: PAM [dlerror: /lib/security/pam_krb5.so:
cannot open shared object file: No such file or directory]
Mar 16 16:01:01 attila crond[22289]: PAM adding faulty module:
/lib/security/pam_krb5.so
Mar 16 16:01:01 attila crond[22290]: (root) CMD (run-parts /etc/cron.hourly)


Version-Release number of selected component (if applicable):
Probably vixie-cron-4.1-10.EL3


Additional info:
pam_krb5 RPM is not installed.
This seems related to Bug # 178931, which is for Fedora Core 4.
Comment 1 Jason Vas Dias 2006-03-16 16:55:40 EST
It appears you do not have the pam_krb5 package installed.  

You can resolve this bug by removing this line from /etc/pam.d/crond:
'
session optional     pam_krb5.so
'

Actually, it became apparent that the pam_krb5.so module performed no
useful function for crond's session PAM stack; so it was removed with
vixie-cron-4.1-11.EL3, which fixes this bug by removing the pam_krb5 line, 
and is available from:
  http://people.redhat.com/~jvdias/vixie-cron/RHEL-3
Comment 2 Marc Desrochers 2006-03-16 17:45:55 EST
What is the timeframe for availability of the RPM by RHN ?  As most
of our affected stations are in Production and this behaviour is in
fact only a nuisance, we prefer to wait until the RPM is officially
distributed (although we may implement the fix you mention manually
while waiting).
Comment 3 Jason Vas Dias 2006-03-16 17:53:07 EST
vixie-cron-4.1-11.EL3+ would be a candidate for inclusion in RHEL-3-U8, coming
out in a few months .   
Comment 4 Marc Desrochers 2006-03-16 18:38:36 EST
Works for us, thank you.

I expect that you can mark the bug resolved.
Comment 5 Peter Bieringer 2006-03-17 04:38:12 EST
Same happen to us here on customer machines, updated to U7. Looks like
/etc/pam.d/crond was also new introduced in U7, vixie-cron of U6 has't included
such file.
Note that RHEL 4ES U3 also doesn't contain this pam_krb5 line.

I hope that vixie-cron-4.1-11.EL3 will be pushed very soon to up2date -
otherwise customers will be very unhappy... 
Comment 13 Red Hat Bugzilla 2006-04-19 14:59:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0301.html

Note You need to log in before you can comment on or make changes to this bug.