Bug 185700 - Please compile with LDAP option
Summary: Please compile with LDAP option
Status: CLOSED DUPLICATE of bug 170848
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sudo (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-16 22:50 UTC by jeff+redhat
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-16 23:06:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jeff+redhat 2006-03-16 22:50:19 UTC
Description of problem:
It would be nice if the version of sudo distributed with RHEL had the LDAP
option for sudo. Right now you either need to maintain a seperate sudoers file
for each server or distribute an updated file to every server when any change is
made. If the LDAP option was available. At the least please provide a second
build that can be installed instead of the main sudo package. (This is the
approach debian has taken. It has both a sudo and a sudo-ldap package. See
http://packages.debian.org/testing/admin/sudo-ldap.) 

The upstream page about ldap support is at
http://www.gratisoft.us/sudo/readme_ldap.html.

Comment 1 Karel Zak 2006-03-16 23:06:56 UTC
This request has beem already rejected for RHEL4. See bug #170848. The RHEL5
seems like better idea.

*** This bug has been marked as a duplicate of 170848 ***

Comment 2 jeff+redhat 2006-03-16 23:12:02 UTC
I'm getting an access denied error on that bug. Can you either open it up for
access or tell me what it says?

Comment 3 Karel Zak 2006-03-16 23:23:34 UTC
It seems like risk do this kind of change for package like sudo when we talk
about __update__ to already stable distribution (like RHEL4). We prefer only
real bug fixes. I think you understand that reliability and stability is more
important. We will probably support sudo+ldap in RHEL5. Sorry.

Comment 4 jeff+redhat 2006-03-16 23:25:26 UTC
When I filled this bug I wasn't talking about adding it to RHEL4. I was
suggesting that it be supported when RHEL5 was released.


Note You need to log in before you can comment on or make changes to this bug.