This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185723 - NPE when opening Bug Systems view
NPE when opening Bug Systems view
Status: CLOSED DUPLICATE of bug 182711
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kyu Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-17 00:14 EST by Eugene Kuleshov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 11:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Kuleshov 2006-03-17 00:14:53 EST
Description of problem:

NPE on opening Bug systems view. Exception appears in the vew itself:

java.lang.NullPointerException
	at
org.eclipse.team.bugzilla.persistence.ProviderPersistenceAdapter.restore(ProviderPersistenceAdapter.java:65)
	at
org.eclipse.team.bugzilla.persistence.ContainerPersistenceAdapter.restore(ContainerPersistenceAdapter.java:42)
	at
org.eclipse.team.bugzilla.persistence.AbstractPersistenceAdapter.restoreElement(AbstractPersistenceAdapter.java:157)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreChild(PersistenceManager.java:169)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreChildren(PersistenceManager.java:197)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreProviders(PersistenceManager.java:138)
	at
org.eclipse.team.bugzilla.BugzillaFactory.getStoredProviders(BugzillaFactory.java:44)
	at
org.eclipse.team.bugs.internal.main.StoredProvidersManager.instantiateStoredProviders(StoredProvidersManager.java:71)
	at
org.eclipse.team.bugs.internal.main.StoredProvidersManager.getStoredProviders(StoredProvidersManager.java:54)
	at org.eclipse.team.bugs.extension.Providers.<init>(Providers.java:91)
	at org.eclipse.team.bugs.extension.Providers.getInstance(Providers.java:46)
	at org.eclipse.team.bugs.internal.views.BugView.createPartControl(BugView.java:53)
	at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:331)
	at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:196)
	at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:555)
	at org.eclipse.ui.internal.Perspective.showView(Perspective.java:1656)
	at org.eclipse.ui.internal.WorkbenchPage.busyShowView(WorkbenchPage.java:942)
	at org.eclipse.ui.internal.WorkbenchPage.access$13(WorkbenchPage.java:925)
	at org.eclipse.ui.internal.WorkbenchPage$13.run(WorkbenchPage.java:3273)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3270)
	at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3248)
	at org.eclipse.ui.handlers.ShowViewHandler.openView(ShowViewHandler.java:146)
	at org.eclipse.ui.handlers.ShowViewHandler.openOther(ShowViewHandler.java:102)
	at org.eclipse.ui.handlers.ShowViewHandler.execute(ShowViewHandler.java:70)
	at org.eclipse.ui.internal.ShowViewMenu$3.run(ShowViewMenu.java:113)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:492)
	at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:530)
	at
org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:480)
	at
org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:392)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:925)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3287)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2907)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1899)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1863)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:417)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:106)
	at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:99)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:374)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:169)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:338)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:282)
	at org.eclipse.core.launcher.Main.run(Main.java:977)
	at org.eclipse.core.launcher.Main.main(Main.java:952)

Version-Release number of selected component (if applicable):

Last plugin from the update site. Eclipse 3.2M5, Java5

How reproducible:

Always

Steps to Reproduce:
1. Install plugin on Eclipse 3.2M5 (Java5)
2. Restart Eclise
3. Try to open Bug Systems view.
4. Watch excepton
  
Actual results:


Expected results:


Additional info:
Comment 1 Igor Foox 2006-03-17 10:21:19 EST
Hi Eugene,

Please take a look at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=182711 for a workaround for
this, this will be fixed in the next version.
Comment 2 Kyu Lee 2006-08-30 11:55:00 EDT

*** This bug has been marked as a duplicate of 182711 ***

Note You need to log in before you can comment on or make changes to this bug.