Bug 185724 - lockup on accessing second sata drive (Maxtor 6V250F0)
lockup on accessing second sata drive (Maxtor 6V250F0)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
http://lkml.org/lkml/2006/3/16/369
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-17 00:52 EST by Samuel Masham
Modified: 2013-07-02 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Masham 2006-03-17 00:52:03 EST
Description of problem:  
  
lockup when accessing a second sata disk Maxtor 6V250F0. 
 
This lockup prevents any access to eather drive effectively brining the box 
down. It needs a hard reset to recover. 
 
(from lspci) 
00:1f.2 IDE interface: Intel Corporation 6300ESB SATA Storage Controller (rev 
02) (prog-if 8a [Master SecP PriP]) 
 
Version-Release number of selected component (if applicable):  
  
Linux anago.stb.sony.co.jp 2.4.21-40.ELsmp #1 SMP Thu Feb 2 22:22:39 EST 2006  
i686 i686 i386 GNU/Linux  
  
How reproducible:  
  
On one box 100%  
  
other boxes (we have 10 identical boxes here) less easy but still happens... 
 
Steps to Reproduce:  
1. mkfs -t ext3 /dev/sdb2  
2.  
3.  
    
Actual results:  
  
anago:[root]% mkfs -t ext3 /dev/sdb2  
mke2fs 1.32 (09-Nov-2002)  
Filesystem label=  
OS type: Linux  
Block size=4096 (log=2)  
Fragment size=4096 (log=2)  
20430848 inodes, 40853295 blocks  
2042664 blocks (5.00%) reserved for the super user  
First data block=0  
1247 block groups  
32768 blocks per group, 32768 fragments per group  
16384 inodes per group  
Superblock backups stored on blocks:  
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632,  
2654208,  
        4096000, 7962624, 11239424, 20480000, 23887872  
  
Writing inode tables:  733/1247        
  
....and then no more (actually since the update the block number we stick on  
has moved slightly)  
 
on the console 
 
ata1: command 0x35 timeout, stat 0xd1 host_stat 0x61 
ata1: translated ATA stat/err 0xd1/00 to SCSI SK/ASC/ASCQ 0xb/47/00 
ata1: status=0xd1 { Busy } 
SCSI disk error : host 0 channel 0 id 1 lun 0 return code = 8000002 
Current sd08:12: sense key Aborted Command 
Additional sense indicates Scsi parity error 
 I/O error: dev 08:12, sector 89391226 
ATA: abnormal status 0xD1 on port 0x177 
ATA: abnormal status 0xD1 on port 0x177 
ATA: abnormal status 0xD1 on port 0x177 
ata1: command 0x35 timeout, stat 0xd1 host_stat 0x61 
ata1: translated ATA stat/err 0xd1/00 to SCSI SK/ASC/ASCQ 0xb/47/00 
ata1: status=0xd1 { Busy } 
SCSI disk error : host 0 channel 0 id 1 lun 0 return code = 8000002 
Current sd08:12: sense key Aborted Command 
Additional sense indicates Scsi parity error 
 I/O error: dev 08:12, sector 89391228 
ATA: abnormal status 0xD1 on port 0x177 
ATA: abnormal status 0xD1 on port 0x177 
ATA: abnormal status 0xD1 on port 0x177 
  
Expected results:  
  
the command should complete giving a valid ext3 partition   
  
Additional info:  
 
system information can be seen here:- 
 
https://rhn.redhat.com/network/systems/details/hardware.pxt?sid=1004616728 
 
(if you can follow that?) 
 
What seems to happen is that mkfs will try and write to the drive 
using the normal 
 
(From strace) 
 
_llseek(3, 72613699584, [72613699584], SEEK_SET) = 0 
write(3, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 32768 
 
but this write then "never" returns... 
 
from the echo t > /proc/sysrq-trigger output 
 
mkfs.ext3     R F6EA8000  3872 22820  22819                     (NOTLB) 
Call Trace:   [<c01355d5>] schedule_timeout [kernel] 0x65 (0xd5233cd4) 
[<c0135560>] process_timeout [kernel] 0x0 (0xd5233cf4) 
[<c012569d>] io_schedule_timeout [kernel] 0x2d (0xd5233d0c) 
[<c01d33fa>] __get_request_wait [kernel] 0xfa (0xd5233d18) 
[<c01d3a5c>] __make_request [kernel] 0x15c (0xd5233d74) 
[<c01d40da>] generic_make_request [kernel] 0xea (0xd5233dd0) 
[<c01d4179>] submit_bh_rsector [kernel] 0x49 (0xd5233df8) 
[<c01667bb>] write_locked_buffers [kernel] 0x3b (0xd5233e14) 
[<c0166930>] write_some_buffers [kernel] 0x160 (0xd5233e28) 
[<c0167b24>] balance_dirty [kernel] 0x34 (0xd5233ecc) 
[<c0168aa4>] __block_commit_write [kernel] 0x84 (0xd5233ed8) 
[<c01692dd>] block_commit_write [kernel] 0x2d (0xd5233ef4) 
[<c014c6d5>] do_generic_file_write [kernel] 0x235 (0xd5233f0c) 
[<c014cc4f>] generic_file_write [kernel] 0x18f (0xd5233f60) 
[<c0165267>] sys_write [kernel] 0x97 (0xd5233f94) 
[<c01110d9>] syscall_trace_enter [kernel] 0x59 (0xd5233fac) 
[<c02af114>] no_timing2 [kernel] 0x7 (0xd5233fc0) 
[<c02a002b>] clip_pop [kernel] 0x5b (0xd5233fe0) 
 
The value of R varies with it sometime being 00000001  or a number 
like F6758000 
 
 
the boot log (up to userspace) follows 
 
Linux version 2.4.21-40.ELsmp (bhcompile@hs20-bc1-7.build.redhat.com) (gcc 
version 3.2.3 20030502 (Red Hat Linux 3.2.3-54)) #1 SMP Thu Feb 2 22:22:39 EST 
2006 
BIOS-provided physical RAM map: 
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable) 
 BIOS-e820: 0000000000100000 - 000000007ffc0000 (usable) 
 BIOS-e820: 000000007ffc0000 - 000000007ffcfc00 (ACPI data) 
 BIOS-e820: 000000007ffcfc00 - 000000007ffff000 (reserved) 
 BIOS-e820: 00000000fec00000 - 00000000fec90000 (reserved) 
 BIOS-e820: 00000000fed20000 - 00000000fed8ffff (reserved) 
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved) 
 BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved) 
1151MB HIGHMEM available. 
896MB LOWMEM available. 
found SMP MP-table at 000fe710 
hm, page 000fe000 reserved twice. 
hm, page 000ff000 reserved twice. 
hm, page 000f0000 reserved twice. 
NX protection not present; using segment protection 
On node 0 totalpages: 524224 
zone(0): 4096 pages. 
zone(1): 225280 pages. 
zone(2): 294848 pages. 
ACPI: Searched entire block, no RSDP was found. 
ACPI: RSDP located at physical address c00fdc40 
RSD PTR  v0 [DELL  ] 
__va_range(0xfdc54, 0x24): idx=33 mapped at fffdd000 
__va_range(0xfdc54, 0x30): idx=33 mapped at fffdd000 
ACPI table found: RSDT v1 [DELL   PE750    0.1] 
__va_range(0xfdc84, 0x24): idx=33 mapped at fffdd000 
__va_range(0xfdc84, 0x74): idx=33 mapped at fffdd000 
ACPI table found: FACP v1 [DELL   PE750    0.1] 
__va_range(0xfdcf8, 0x24): idx=33 mapped at fffdd000 
__va_range(0xfdcf8, 0x74): idx=33 mapped at fffdd000 
ACPI table found: APIC v1 [DELL   PE750    0.1] 
__va_range(0xfdcf8, 0x74): idx=33 mapped at fffdd000 
LAPIC (acpi_id[0x0001] id[0x0] enabled[1]) 
CPU 0 (0x0000) enabledProcessor #0 Pentium 4(tm) XEON(tm) APIC version 20 
 
LAPIC (acpi_id[0x0002] id[0x1] enabled[0]) 
CPU 1 (0x0100) disabled 
IOAPIC (id[0x1] address[0xfec00000] global_irq_base[0x0]) 
IOAPIC (id[0x2] address[0xfec10000] global_irq_base[0x18]) 
LAPIC_NMI (acpi_id[0x0001] polarity[0x1] trigger[0x1] lint[0x1]) 
LAPIC_NMI (acpi_id[0x0002] polarity[0x1] trigger[0x1] lint[0x1]) 
INT_SRC_OVR (bus[0] irq[0x0] global_irq[0x2] polarity[0x0] trigger[0x0]) 
INT_SRC_OVR (bus[0] irq[0x9] global_irq[0x9] polarity[0x1] trigger[0x3]) 
2 CPUs total 
Local APIC address fee00000 
__va_range(0xfdd6c, 0x24): idx=33 mapped at fffdd000 
__va_range(0xfdd6c, 0x50): idx=33 mapped at fffdd000 
ACPI table found: SPCR v1 [DELL   PE750    0.1] 
Enabling the CPU's according to the ACPI table 
Intel MultiProcessor Specification v1.4 
    Virtual Wire compatibility mode. 
OEM ID: DELL     Product ID: PE 0165      APIC at: 0xFEE00000 
I/O APIC #1 Version 32 at 0xFEC00000. 
I/O APIC #2 Version 32 at 0xFEC10000. 
Processors: 1 
xAPIC support is present 
Enabling APIC mode: Flat.       Using 2 I/O APICs 
Kernel command line: ro root=LABEL=/ apic console=ttyS0,9600 
Initializing CPU#0 
Detected 3400.149 MHz processor. 
Console: colour VGA+ 80x25 
Calibrating delay loop... 6789.52 BogoMIPS 
Page-cache hash table entries: 524288 (order: 9, 2048 KB) 
Page-pin hash table entries: 131072 (order: 7, 512 KB) 
Dentry cache hash table entries: 262144 (order: 9, 2048 KB) 
Inode cache hash table entries: 131072 (order: 8, 1024 KB) 
Buffer cache hash table entries: 131072 (order: 7, 512 KB) 
Memory: 2050524k/2096896k available (1727k kernel code, 41764k reserved, 1304k 
data, 228k init, 1179392k highmem) 
Mount cache hash table entries: 512 (order: 0, 4096 bytes) 
CPU: Trace cache: 12K uops 
CPU: L1 I-cache: 0K, L1 D-cache: 8K 
CPU: L2 cache: 512K 
CPU: Hyper-Threading is disabled 
Intel machine check architecture supported. 
Intel machine check reporting enabled on CPU#0. 
Enabling fast FPU save and restore... done. 
Enabling unmasked SIMD FPU exception support... done. 
Checking 'hlt' instruction... OK. 
POSIX conformance testing by UNIFIX 
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au) 
mtrr: detected mtrr type: Intel 
CPU: Trace cache: 12K uops 
CPU: L1 I-cache: 0K, L1 D-cache: 8K 
CPU: L2 cache: 512K 
CPU: Hyper-Threading is disabled 
Intel machine check reporting enabled on CPU#0. 
CPU0: Intel(R) Pentium(R) 4 CPU 3.40GHz stepping 09 
per-CPU timeslice cutoff: 1462.71 usecs. 
task migration cache decay timeout: 10 msecs. 
enabled ExtINT on CPU#0 
ESR value before enabling vector: 00000000 
ESR value after enabling vector: 00000000 
Error: only one processor found. 
ENABLING IO-APIC IRQs 
Setting 1 in the phys_id_present_map 
...changing IO-APIC physical APIC ID to 1 ... ok. 
Setting 2 in the phys_id_present_map 
...changing IO-APIC physical APIC ID to 2 ... ok. 
..TIMER: vector=0x31 pin1=2 pin2=0 
testing the IO APIC....................... 
 
 
.................................... done. 
Using local APIC timer interrupts. 
calibrating APIC timer ... 
..... CPU clock speed is 3400.3046 MHz. 
..... host bus clock speed is 200.0177 MHz. 
cpu: 0, clocks: 2000177, slice: 1000088 
CPU0<T0:2000176,T1:1000080,D:8,S:1000088,C:2000177> 
zapping low mappings. 
Process timing init...done. 
Starting migration thread for cpu 0 
PCI: PCI BIOS revision 2.10 entry at 0xfc9de, last bus=3 
PCI: Using configuration type 1 
PCI: Probing PCI hardware 
PCI: Ignoring BAR0-3 of IDE controller 00:1f.2 
Transparent bridge - Intel Corp. 82801BA/CA/DB/EB PCI Bridge 
PCI: Using IRQ router PIIX [8086/25a1] at 00:1f.0 
PCI->APIC IRQ transform: (B0,I29,P0) -> 16 
PCI->APIC IRQ transform: (B0,I29,P1) -> 19 
PCI->APIC IRQ transform: (B0,I29,P3) -> 23 
PCI->APIC IRQ transform: (B0,I31,P0) -> 17 
PCI->APIC IRQ transform: (B0,I31,P1) -> 17 
PCI->APIC IRQ transform: (B1,I1,P0) -> 18 
PCI->APIC IRQ transform: (B3,I2,P0) -> 21 
isapnp: Scanning for PnP cards... 
isapnp: No Plug & Play device found 
Linux NET4.0 for Linux 2.4 
Based upon Swansea University Computer Society NET3.039 
Initializing RT netlink socket 
apm: BIOS not found. 
Total HugeTLB memory allocated, 0 
Starting kswapd 
allocated 32 pages and 32 bhs reserved for the highmem bounces 
VFS: Disk quotas vdquot_6.5.1 
aio_setup: num_physpages = 131056 
aio_setup: sizeof(struct page) = 60 
Hugetlbfs mounted. 
pty: 2048 Unix98 ptys configured 
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ 
SERIAL_PCI ISAPNP enabled 
ttyS0 at 0x03f8 (irq = 4) is a 16550A 
Real Time Clock Driver v1.10e 
NET4: Frame Diverter 0.46 
RAMDISK driver initialized: 256 RAM disks of 8192K size 1024 blocksize 
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4 
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx 
hda: SAMSUNG CD-ROM SN-124, ATAPI CD/DVD-ROM drive 
ide1: ports already in use, skipping probe 
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14 
ide-floppy driver 0.99.newide 
ide-floppy driver 0.99.newide 
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27 
md: Autodetecting RAID arrays. 
md: autorun ... 
md: ... autorun DONE. 
pci_hotplug: PCI Hot Plug PCI Core version: 0.5 
Initializing Cryptographic API 
NET4: Linux TCP/IP 1.0 for NET4.0 
IP: routing cache hash table of 16384 buckets, 128Kbytes 
TCP: Hash tables configured (established 524288 bind 65536) 
Linux IP multicast router 0.06 plus PIM-SM 
Initializing IPsec netlink socket 
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0. 
RAMDISK: Compressed image found at block 0 
Freeing initrd memory: 265k freed 
VFS: Mounted root (ext2 filesystem). 
Red Hat nash verSCSI subsystem driver Revision: 1.00 
sion 3.5.13.6 stPCI(00:1f.2): arting 
Mounted combined mode detected (p=0, s=1) 
/proc filesystemata: 0x1f0 IDE port busy 
 
Loading scsi_mata1: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xFEA8 irq 15 
od.o module 
Loading sd_mod.o module 
Loading libata.o module 
Loading scsi_dump_register.o module 
Loading ata_piix.o module 
ata1: dev 0 ATA-7, max UDMA/133, 156250000 sectors: LBA 
ata1: dev 1 ATA-7, max UDMA/133, 490234752 sectors: LBA48 
ata1: dev 0 configured for UDMA/133 
ata1: dev 1 configured for UDMA/133 
scsi0 : ata_piix 
  Vendor: ATA       Model: Maxtor 6Y080M0    Rev: YAR5 
  Type:   Direct-Access                      ANSI SCSI revision: 05 
  Vendor: ATA       Model: Maxtor 6V250F0    Rev: VA11 
  Type:   Direct-Access                      ANSI SCSI revision: 05 
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0 
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0 
SCSI device sda: 156250000 512-byte hdwr sectors (80000 MB) 
Partition check: 
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 sda9 sda10 > 
SCSI device sdb: 490234752 512-byte hdwr sectors (251000 MB) 
 sdb: sdb1 sdb2 
Loading jbd.o moJournalled Block Device driver loaded 
dule 
Loading ext3.o module 
Creating block devices 
Creating root devEXT3-fs: INFO: recovery required on readonly filesystem. 
ice 
Mounting roXT3-fs: write access will be enabled during recovery. 
ot filesystem 
kjournald starting.  Commit interval 5 seconds 
EXT3-fs: recovery complete. 
EXT3-fs: mounted filesystem with ordered data mode. 
Freeing unused kernel memory: 228k freed
Comment 1 Samuel Masham 2006-03-22 20:09:43 EST
Original info was at 
http://lkml.org/lkml/2006/3/16/369 
 
In addition: 
 
I have now talked with Maxtor and found that the drives do have the latest 
(nvida4 bugfix) firmware. 
 
I have retested with shorter new cables with the same result. 
 
I would like to confirm that in the Device Configuration Overlay the NCQ is 
disabled but no idea how to read that... 
 
Any ideas how we can work around or fix this issue? 
 
I reported this update to the  http://lkml.org/lkml/2006/3/22/122 but as yet 
no ideas what to try next. 
Comment 2 Samuel Masham 2006-03-24 05:15:30 EST
The issue also occurs when:  
  
1, only the cdrom and the  6V250F0 are present 
2, a 2.6.12 kernel is used  
 
ie I just unplugged the first sata disk and rebooted from an old knoppix disk 
that I had around and reproduced this issue  
 
its *really* 100% reproducible! 
Comment 3 Ronald Wahl 2006-05-01 08:21:15 EDT
Are there any news on this topic? The related thread on LKML seems death since
end of march. Today I had similar issue (parity error on the second of my two
6V300F0 (Firmware VA111630) with FC5 with the 2.6.16-1.2096_FC5smp kernel.
Comment 4 Ronald Wahl 2006-05-03 01:43:53 EDT
Now is the second morning where this bug occures (during/after the cron.daily
scripts are run shortly 4:00 AM - I guess updatedb). Yesterday a kernel crash
happened because of a NULL pointer dereference. There was even an interesting
SELinux denial message before:

May  2 04:05:11 rohan kernel: audit(1146535511.571:30): avc:  denied  { execheap
} for  pid=11632 comm="ld-linux.so.2" scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

execheap sound strange ... rather like some bad thing happend already. The i/o
errors started 2:30h later. Then this appeared multiple times:

May  2 06:49:33 rohan kernel: Assertion failed! qc !=
NULL,drivers/scsi/libata-core.c,ata_pio_poll,line=2897

followed by the oops with this backtrace:

May  2 06:49:55 rohan kernel: Process ata/1 (pid: 356, threadinfo=f7f4e000
task=f7cce850)
May  2 06:49:55 rohan kernel: Stack: <0>f7cce978 f7e81050 f7d1f310 c241d160
64a95700 003d27ea 00000000 00000001 
May  2 06:49:55 rohan kernel:        00200082 00200282 f7d1f8cc f7d1f8d0
c2648cc0 00200282 c0131394 f88a7334 
May  2 06:49:55 rohan kernel:        f7d1f310 c2648cd8 c2648cc0 c2648ce0
c0131b81 c0131c67 00000000 00000000 
May  2 06:49:55 rohan kernel: Call Trace:
May  2 06:49:55 rohan kernel:  [<c0131394>] run_workqueue+0x7f/0xba    
[<f88a7334>] ata_pio_task+0x0/0x677 [libata]
May  2 06:49:56 rohan kernel:  [<c0131b81>] worker_thread+0x0/0x117    
[<c0131c67>] worker_thread+0xe6/0x117
May  2 06:49:56 rohan kernel:  [<c011da89>] default_wake_function+0x0/0xc    
[<c0134499>] kthread+0x9d/0xc9
May  2 06:49:56 rohan kernel:  [<c01343fc>] kthread+0x0/0xc9     [<c0102005>]
kernel_thread_helper+0x5/0xb

The board is an ASUS P4P800-E Deluxe with Intel ICH5.

Do you need more Info? Shall I file a seperate (more detailed) bug report
against FC5 for this or is it ok to track it here in this report?
Comment 5 Glen Ritchie 2006-05-29 02:36:47 EDT
Hi. After much searching on the internet to solve our problems we too came 
across this bug but on Fedora Core 5, except that we don't seem to get any disk 
error output, HOWEVER we DO have 2 Maxtor drives set up to use software raid.

Also, i'd like to mention that i found this in the intel docs for linux and RH9:
ftp://download.intel.com/design/motherbd/linux/RedHat9_info.pdf

-- Currently Red Hat 9.0 does not natively support Serial ATA disk drive 
configurations running in "Enhanced" mode. You must set the Intel(R) desktop
board to run in "Legacy" mode to install the operating system on a SATA disk 
drive. NOTE: When in "Legacy" mode you are limited to a combination of 4
storage devices (for example, 2 SATA and/or 2 PATA disk drives, or 4 PATA disk 
drives).

I havn't had a chance to try this yet though to see if it fixes our problems.

Below are some details that may/may not help. It certainly is an interesting 
bug.

Here's the details:
[root@ log]# uname -a
Linux 2.6.15-1.2054_FC5 #1 SMP Tue Mar 14 15:48:20 EST 2006 x86_64 x86_64 x86_64 
GNU/Linux


[root@ log]# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub 
Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics 
Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI 
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface 
Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 
02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) 
AC'97 Audio Controller (rev 02)
01:08.0 Ethernet controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) 
integrated LAN Controller (rev 02)

--------------------------

SCSI subsystem initialized
libata version 1.20 loaded.
ata_piix 0000:00:1f.2: version 1.05
ata_piix 0000:00:1f.2: combined mode detected (p=1, s=0)
GSI 16 sharing vector 0xA9 and IRQ 16
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0xF000 irq 14
ata1: dev 0 cfg 49:2f00 82:7c6b 83:7f09 84:4773 85:7c68 86:3e01 87:4763 88:207f
ata1: dev 0 ATA-7, max UDMA/133, 312579695 sectors: LBA48
ata1: dev 1 cfg 49:2f00 82:7c6b 83:7f09 84:4773 85:7c68 86:3e01 87:4763 88:207f
ata1: dev 1 ATA-7, max UDMA/133, 312581808 sectors: LBA48
ata1: dev 0 configured for UDMA/133
ata1: dev 1 configured for UDMA/133
scsi0 : ata_piix
  Vendor: ATA       Model: Maxtor 6V160E0    Rev: VA11
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 312579695 512-byte hdwr sectors (160041 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 312579695 512-byte hdwr sectors (160041 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda: sda1 sda2
sd 0:0:0:0: Attached scsi disk sda
  Vendor: ATA       Model: Maxtor 6V160E0    Rev: VA11
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
 sdb: sdb1
sd 0:0:1:0: Attached scsi disk sdb
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xF008 irq 15
ata2: disabling port
scsi1 : ata_piix

and lastly
[root@ ~]lshw
    description: Desktop Computer
    width: 32 bits
    capabilities: smbios-2.3 dmi-2.3
    configuration: boot=normal chassis=desktop
  *-core
       description: Motherboard
       product: 8I865GVMK-775
       vendor: Gigabyte Technology Co., Ltd.
       physical id: 0
       version: x.x
     *-firmware
          description: BIOS
          vendor: Award Software International, Inc.
          physical id: 0
          version: F2 (09/16/2005)
          size: 128KB
          capacity: 320KB
          capabilities: pci pnp apm upgrade shadowing cdboot bootselect edd 
int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int5printscreen 
int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot 
biosbootspecification
     *-cpu:0
          description: CPU
          product: Intel(R) Pentium(R) 4 CPU 3.00GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: Intel(R) Pentium(R) 4 CPU
          slot: Socket 775
          size: 3GHz
          capacity: 3600MHz
          width: 64 bits
          clock: 200MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic 
sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm 
syscall nx x86-64 constant_tsc pni monitor ds_cpl est cid cx16 xtpr
        *-cache:0
             description: L1 cache
             physical id: b
             slot: Internal Cache
             size: 16KB
             capacity: 16KB
             capabilities: synchronous internal write-back
        *-cache:1
             description: L2 cache
             physical id: c
             slot: External Cache
             size: 2MB
             capabilities: synchronous internal write-back
     *-cpu:1
          description: CPU
          product: ( )
          vendor: Intel
          physical id: 5
          bus info: cpu@1
          version: Intel(R) Pentium(R) 4 CPU
          slot: Socket 775
          size: 3GHz
          capacity: 3600MHz
          clock: 200MHz
     *-memory
          description: System Memory
          physical id: 1b
          slot: System board or motherboard
          size: 1GB
        *-bank:0
             description: DIMM 400 MHz (2.5 ns)
             product: None
             vendor: None
             physical id: 0
             serial: None
             slot: A0
             size: 512MB
             width: 64 bits
             clock: 400MHz (2.5ns)
        *-bank:1
             description: DIMM [empty]
             product: None
             vendor: None
             physical id: 1
             serial: None
             slot: A1
        *-bank:2
             description: DIMM 400 MHz (2.5 ns)
             product: None
             vendor: None
             physical id: 2
             serial: None
             slot: A2
             size: 512MB
             width: 64 bits
             clock: 400MHz (2.5ns)
        *-bank:3
             description: DIMM [empty]
             product: None
             vendor: None
             physical id: 3
             serial: None
             slot: A3
     *-pci
          description: Host bridge
          product: 82865G/PE/P DRAM Controller/Host-Hub Interface
          vendor: Intel Corporation
          physical id: e0000000
          bus info: pci@00:00.0
          version: 02
          width: 32 bits
          clock: 33MHz
          resources: iomemory:e0000000-efffffff
        *-display
             description: VGA compatible controller
             product: 82865G Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@00:02.0
             version: 02
             size: 128MB
             width: 32 bits
             clock: 33MHz
             capabilities: vga bus_master cap_list
             resources: iomemory:f0000000-f7ffffff iomemory:f8100000-f817ffff 
ioport:c000-c007 irq:19
        *-usb:0
             description: USB Controller
             product: 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1
             vendor: Intel Corporation
             physical id: 1d
             bus info: pci@00:1d.0
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: uhci bus_master
             configuration: driver=uhci_hcd
             resources: ioport:b000-b01f irq:19
           *-usbhost
                product: UHCI Host Controller
                vendor: Linux 2.6.15-1.2054_FC5 uhci_hcd
                physical id: 1
                bus info: usb@1
                logical name: usb1
                version: 2.06
                capabilities: usb-1.10
                configuration: driver=hub maxpower=0mA slots=2 speed=12.0MB/s
        *-usb:1
             description: USB Controller
             product: 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2
             vendor: Intel Corporation
             physical id: 1d.1
             bus info: pci@00:1d.1
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: uhci bus_master
             configuration: driver=uhci_hcd
             resources: ioport:b400-b41f irq:20
           *-usbhost
                product: UHCI Host Controller
                vendor: Linux 2.6.15-1.2054_FC5 uhci_hcd
                physical id: 1
                bus info: usb@2
                logical name: usb2
                version: 2.06
                capabilities: usb-1.10
                configuration: driver=hub maxpower=0mA slots=2 speed=12.0MB/s
        *-usb:2
             description: USB Controller
             product: 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3
             vendor: Intel Corporation
             physical id: 1d.2
             bus info: pci@00:1d.2
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: uhci bus_master
             configuration: driver=uhci_hcd
             resources: ioport:b800-b81f irq:16
           *-usbhost
                product: UHCI Host Controller
                vendor: Linux 2.6.15-1.2054_FC5 uhci_hcd
                physical id: 1
                bus info: usb@3
                logical name: usb3
                version: 2.06
                capabilities: usb-1.10
                configuration: driver=hub maxpower=0mA slots=2 speed=12.0MB/s
        *-usb:3
             description: USB Controller
             product: 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4
             vendor: Intel Corporation
             physical id: 1d.3
             bus info: pci@00:1d.3
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: uhci bus_master
             configuration: driver=uhci_hcd
             resources: ioport:bc00-bc1f irq:19
           *-usbhost
                product: UHCI Host Controller
                vendor: Linux 2.6.15-1.2054_FC5 uhci_hcd
                physical id: 1
                bus info: usb@4
                logical name: usb4
                version: 2.06
                capabilities: usb-1.10
                configuration: driver=hub maxpower=0mA slots=2 speed=12.0MB/s
        *-usb:4
             description: USB Controller
             product: 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
             vendor: Intel Corporation
             physical id: 1d.7
             bus info: pci@00:1d.7
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: ehci bus_master cap_list
             configuration: driver=ehci_hcd
             resources: iomemory:f8180000-f81803ff irq:21
           *-usbhost
                product: EHCI Host Controller
                vendor: Linux 2.6.15-1.2054_FC5 ehci_hcd
                physical id: 1
                bus info: usb@5
                logical name: usb5
                version: 2.06
                capabilities: usb-2.00
                configuration: driver=hub maxpower=0mA slots=8 speed=480.0MB/s
        *-pci
             description: PCI bridge
             product: 82801 PCI Bridge
             vendor: Intel Corporation
             physical id: 1e
             bus info: pci@00:1e.0
             version: c2
             width: 32 bits
             clock: 33MHz
             capabilities: pci normal_decode bus_master
           *-network
                description: Ethernet interface
                product: 82801EB/ER (ICH5/ICH5R) integrated LAN Controller
                vendor: Intel Corporation
                physical id: 8
                bus info: pci@01:08.0
                logical name: eth0
                version: 02
                serial: 00:14:85:c5:4c:98
                size: 100MB/s
                capacity: 100MB/s
                width: 32 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical tp mii 10bt 
10bt-fd 100bt 100bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=e100 
driverversion=3.5.10-k2-NAPI duplex=full firmware=N/A ip=192.168.0.14 link=yes 
multicast=yes port=MII speed=100MB/s
                resources: iomemory:f8000000-f8000fff ioport:a000-a03f irq:17
        *-isa UNCLAIMED
             description: ISA bridge
             product: 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge
             vendor: Intel Corporation
             physical id: 1f
             bus info: pci@00:1f.0
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: isa bus_master
        *-ide
             description: IDE interface
             product: 82801EB (ICH5) SATA Controller
             vendor: Intel Corporation
             physical id: 1f.2
             bus info: pci@00:1f.2
             logical name: scsi0
             version: 02
             width: 32 bits
             clock: 66MHz
             capabilities: ide bus_master emulated
             configuration: driver=ata_piix
             resources: ioport:f000-f00f irq:16
           *-disk:0
                description: SCSI Disk
                product: Maxtor 6V160E0
                vendor: ATA
                physical id: 0.0.0
                bus info: scsi@0:0.0.0
                logical name: /dev/sda
                version: VA11
                serial: V39AEFGG
                size: 149GB
                capabilities: partitioned partitioned:dos
                configuration: ansiversion=5
              *-volume:0
                   description: Linux filesystem partition
                   physical id: 1
                   bus info: scsi@0:0.0.0,1
                   logical name: /dev/sda1
                   capacity: 101MB
                   capabilities: primary bootable
              *-volume:1
                   description: Linux LVM partition
                   physical id: 2
                   bus info: scsi@0:0.0.0,2
                   logical name: /dev/sda2
                   capacity: 148GB
                   capabilities: primary multi
           *-disk:1
                description: SCSI Disk
                product: Maxtor 6V160E0
                vendor: ATA
                physical id: 0.1.0
                bus info: scsi@0:0.1.0
                logical name: /dev/sdb
                version: VA11
                serial: V395DFEG
                size: 149GB
                capabilities: partitioned partitioned:dos
                configuration: ansiversion=5
              *-volume
                   description: Linux LVM partition
                   physical id: 1
                   bus info: scsi@0:0.1.0,1
                   logical name: /dev/sdb1
                   capacity: 149GB
                   capabilities: primary bootable multi
        *-serial
             description: SMBus
             product: 82801EB/ER (ICH5/ICH5R) SMBus Controller
             vendor: Intel Corporation
             physical id: 1f.3
             bus info: pci@00:1f.3
             version: 02
             width: 32 bits
             clock: 33MHz
             configuration: driver=i801_smbus
             resources: ioport:1400-141f irq:9
        *-multimedia
             description: Multimedia audio controller
             product: 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
             vendor: Intel Corporation
             physical id: 1f.5
             bus info: pci@00:1f.5
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: driver=Intel ICH
             resources: ioport:dc00-dcff ioport:e000-e03f iomemory:f8181000-
f81811ff iomemory:f8182000-f81820ff irq:18

Comment 6 Ronald Wahl 2006-05-29 14:32:34 EDT
For me the problem _seems_ to be gone since I switched the irq balancer off
(this is a system daemon). On a P4 with Hyperthreading (my platform) this makes
not much sense I think. Some other problems are gone too with this change -
e.g.the jiffi counters in /proc/stat run factor 10x slower than usual sometimes.
Dunno if there is a direct relation but at least I havn't seen any anomalies
since then.
Comment 7 Ronald Wahl 2006-06-14 00:40:11 EDT
Unfortunately the bug occured again - after more than a month of working. The
second disc - respective my whole system - was freezed again this morning.

...
Jun 14 03:34:40 rohan kernel: ata2: command 0xb0 timeout, stat 0xd0 host_stat 0x0
Jun 14 03:34:40 rohan kernel: ata2: status=0xd0 { Busy }
...
Jun 14 03:34:50 rohan kernel: Assertion failed! qc !=
NULL,drivers/scsi/libata-core.c,ata_pio_poll,line=2897
Jun 14 03:35:10 rohan last message repeated 1241 times
Jun 14 03:35:10 rohan kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000094
...
Comment 8 RHEL Product and Program Management 2007-10-19 14:46:04 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.