Bug 18575 - Strange X Windows Problem
Strange X Windows Problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 17:49 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 02:19:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 17:49:15 EDT
I'm having a very odd problem with RedHat7.0 ... seems that if my computer
sits dormant for any length of time X stops responding completely. If I
leave X running and come back everything looks normal, but nothing responds
... the mouse still moves the cursor around but no programs will respond
... even the logout does nothing and i have to ctrl+alt+backspace to get
out. If I exit out of X (even all the way out to the main login) and leave
the system dormant when i come back and log back in X wont even start. To
get anything X related to function I have to actually reboot the computer.
Comment 1 Alan Cox 2000-10-09 20:07:10 EDT
Do you have power saving enabled in the bios ?
Comment 2 Need Real Name 2000-10-10 12:38:25 EDT
Power management is enabled in BIOS. I dual boot with Win98 and would prefer to
keep it enabled as Windows uses the power management features without issue.
Comment 3 Mike A. Harris 2001-03-20 02:19:13 EST
The idea here is to find out what is causing the problem.  If you are
interested in solving this problem, please try the following:

Disable the Linux screensavers entirely, including monitor powerdown, etc.
Does the problem disappear?
If not, disable Power management in the BIOS as Alan eluded to.  Boot
Linux, and try to reproduce the lockup.
Does the problem diisappear?  If so, then we've located the problem.
If the problem is in fact power management related, leave the BIOS power
management off, and have windows do power management using other mechanisms
if possible.

Another alternative for you is to try our latest XFree86 4.0.3 release
which may in fact solve the problem for you if it is in fact XFree86 related.
You'll also need Mesa 3.4-13. You can obtain these at:

http://people.redhat.com/mharris

You can find any other dependant packages in rawhide.  If this does not solve
the problem for you I will need a copy of your Xserver logs from after the
lockup has occured, as well as a copy of your XF86config files.  Please
also attache the output of "lspci -v" and "lspci -vn" as well.  You can attach
these files via the link below.

Hopefully this will solve the problem for you.


Comment 4 Mike A. Harris 2001-08-13 08:29:32 EDT
G200 works in latest release fine, at least I can't reproduce this on
latest release.

Note You need to log in before you can comment on or make changes to this bug.