Bug 18580 - No PPP Option in netcfg
No PPP Option in netcfg
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: netcfg (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 20:30 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 20:30:50 EDT
I am not sure if this is a bug or a feature.  However, I have been using 
Red Hat Linux since version 3.0.3 and was a very satisfied user. I have 
tried other distributions always finding myself back with redhat.  RedHat 
7.0 seemed like it was going to be great.  However, it was a disaster for 
me. 

Most things worked.  However, PPP configuration does not.  I normally run 
the 'netcfg' utility to set up a dedicated PPP connection that 1) restarts 
when it dies 2) starts itself up on boot up.  This one feature stopped me 
from leaving RedHat.  I just loved the netcfg utility.  

However, with RedHat 7.0, I went to configure my PPP connection (which I 
have gotten working on the first try in every release of RedHat) I was 
left stranded.  I could not get the box on the net to check for any 
thing.  Since documentation was dumped onto another CD, I was left without 
the docs.  So, I started going through the source to netcfg to find out 
where the PPP option had gone to.  Well, I found that it was 'commented 
out'.  So, I naturally uncommented it.  Fired up, netcfg and voila.  PPP 
now existed.  However, it brought up a new utility to manage PPP 
connections. 

Well, I tried using it.  However, since it is based on wvdial, I never 
have gotten it to work.  It did not seem to be doing PAP authentication at 
all or correctly.  Thus I could not get the box online to see whats up 
with the other issues I was having.

Anyway, I directed this bug report to the netcfg people since netcfg is my 
main reason for having to downgrade back to my flawless 6.2 system. 

I loved RedHat for how it handled PPP configurations.  I liked how RedHat 
treated PPP like a real network interface rather than a desktop user's way 
to the net.  Most of my usage of my box is done via remote over that PPP 
connection.

I do not mind when new features are added.  Some, I may start to love.  
However, do not remove portions of utilities that people learn to depend 
on.  I remember reading a bug about linuxconf where you guys said that the 
feature was disabled due to some reason why it would not work or some lack 
of reason.  

Most of the annoyances I find with a RedHat system, I can work around.  
However, my favorite utility being dismantled piece by piece made my gut 
turn.  

I will try RedHat again in 7.1.  However, I am not happy with RedHat 7.0.

You could have at leased presented me with a message stating why this 
functionality has been removed.  You could have given reference to a 
document that is loaded in the system to notify people.  

If a better tool to manage PPP like the way netcfg did comes along, sure 
use it.  I don't want to have to click on icons to start and stop my 
network connections.  I want the system to them at boot up and shutdown.

I could not find this support in the new config tool.  The new config tool 
would not even connect to my standard ISP that has no special requirements.

Please do not blow this off as NOTA.  I would like to know how the 
functionality lost in the removal of PPP from netcfg is obtained.

Jeff - disappointed for the first time since 3.0.3
Comment 1 Need Real Name 2001-02-05 16:55:37 EST
I just tried to upgrade my firewall box to Red Hat 7.0 and have experienced the 
same problem.  I too depend on the PPP connection being configured as a network 
interface so I could use a 3rd party firewall product.  I hope there is a way 
to maintain this type of functionality in 7.0 and use the built in firewall GUI 
to secure it.

Thanks

Sean McCloskey
Comment 2 David Henderson 2001-02-20 16:09:22 EST
I'm having the same problem.  Is there a patch to download?
Comment 3 Bill Nottingham 2006-08-07 15:46:21 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 13:05:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.