Bug 185808 - anaconda-10.1.1.37-1.src.rpm fails to rebuild on RHEL4 Update 3
Summary: anaconda-10.1.1.37-1.src.rpm fails to rebuild on RHEL4 Update 3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-18 16:51 UTC by Johnny Hughes
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 21:43:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full build log (32.14 KB, text/plain)
2006-03-18 16:51 UTC, Johnny Hughes
no flags Details

Description Johnny Hughes 2006-03-18 16:51:04 UTC
Description of problem:
anaconda-10.1.1.37-1.src.rpm fails to rebuild on RHEL4 Update 3

Version-Release number of selected component (if applicable):
anaconda-10.1.1.37-1.src.rpm

How reproducible:
Always


Steps to Reproduce:
1.  rpmbuild --rebuild anaconda-10.1.1.37-1.src.rpm

Actual results:

diet gcc -g -static -o loader loader.o log.o moduleinfo.o loadermisc.o modules.o
moduledeps.o windows.o lang.o kbd.o modstubs.o driverdisk.o selinux.o md5.o
mediacheck.o kickstart.o driverselect.o getparts.o dirbrowser.o pcmcia.o usb.o
firewire.o hardware.o method.o cdinstall.o hdinstall.o nfsinstall.o urlinstall.o
dietstubs.o ctype.o net.o urls.o ftp.o telnet.o telnetd.o -lpopt     \
-lkudzu_loader   -lpci_loader ../isys/libisys-diet.a -lrpc
../isys/gzlib/libgunzip-diet.a \
-lpump -lresolv -lnewt -lslang -lbtermdiet -lbogldiet  -lwlitediet
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x2b9):
In function `entryDraw':
: undefined reference to `__ctype_get_mb_cur_max'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x2cc):
In function `entryDraw':
: undefined reference to `mbtowc'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x329):
In function `entryDraw':
: undefined reference to `__ctype_get_mb_cur_max'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x342):
In function `entryDraw':
: undefined reference to `mbtowc'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x559):
In function `previous_char':
: undefined reference to `__ctype_get_mb_cur_max'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x568):
In function `previous_char':
: undefined reference to `mblen'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x599):
In function `next_char':
: undefined reference to `__ctype_get_mb_cur_max'
/usr/lib/gcc/i386-redhat-linux/3.4.5/../../../libnewt.a(entry.o)(.text+0x5a8):
In function `next_char':
: undefined reference to `mblen'
collect2: ld returned 1 exit status
make[1]: *** [loader] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/anaconda-10.1.1.37/loader2'
make: *** [subdirs] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.4891 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.4891 (%build)

-------------------------------------------------------------------
Expected results:
Builds the RPMS

Comment 1 Johnny Hughes 2006-03-18 16:51:04 UTC
Created attachment 126307 [details]
full build log

Comment 2 Tuomo Soini 2006-03-18 23:20:53 UTC
Switching back to newt-0.51.6-5 makes build happy. And this problem doesn't
happen on x86_64 arch.

Comment 3 Matthew Miller 2006-03-21 14:48:00 UTC
FWIW, anaconda 10.1.1.37 (with many other tweaks unrelated to this) rebuilds
fine on up-to-date FC4 with newt-0.51.6-7.

Comment 4 Chris Lumens 2007-03-14 21:43:32 UTC
This is just spec file problems that have been sorted out with more recent
releases due to internal build system changes being much more strict.


Note You need to log in before you can comment on or make changes to this bug.