Bug 185827 - yum-builddep fails if installed package is no available in yum repositories
Summary: yum-builddep fails if installed package is no available in yum repositories
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-18 22:07 UTC by Noa Resare
Modified: 2014-01-21 22:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 10:29:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noa Resare 2006-03-18 22:07:56 UTC
Description of problem:
If I try to use yum-builddep to build something that has depedencies that I have
installed locally but doesn't exist in my yum repositories it fails with the
message "yum.Errors.YumBaseError: No Package found for LOCALLY_INSTALLED_RPM"

This is reasonable, but I think it would be nice if the utility could recogise
that this dependency is already satisfied by the installed rpms.



Version-Release number of selected component (if applicable):
yum-utils-0.5-1

Comment 1 Tim Lauridsen 2007-02-06 10:52:20 UTC
Please retest with latest yum & yum-util and report back

Comment 2 Tim Lauridsen 2007-02-14 10:29:25 UTC
I closing this one, if there still is a problem the reopen.


Note You need to log in before you can comment on or make changes to this bug.