Bug 185835 - Bind mounts listed in /etc/fstab confuse anaconda and cause upgrades to fail
Bind mounts listed in /etc/fstab confuse anaconda and cause upgrades to fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-19 03:25 EST by Nicholas Miell
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 10:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (13.09 KB, text/plain)
2006-03-29 17:14 EST, Nicholas Miell
no flags Details

  None (edit)
Description Nicholas Miell 2006-03-19 03:25:01 EST
If there are any bind mounts listed in /etc/fstab,
anaconda gives the following error message:

"Error mounting device /mnt/storage/nicholas/media as /home/nicholas/media: No
such file or directory.

This most likely means this partition has not been formatted.

Press OK to reboot your system."

The fstab line which caused this error was:
/mnt/storage/nicholas/media /home/nicholas/media auto bind 0 0
Comment 1 Chris Lumens 2006-03-20 16:35:43 EST
What is the actual type of the filesystem you're trying to bind mount?
Comment 2 Nicholas Miell 2006-03-20 19:46:25 EST
ext3. That shouldn't matter, though, for a bind mount.

Perhaps anaconda isn't mounting filesystems listed in /etc/fstab in order? Or
maybe it's treating the bind keyword as an option to be passed to the filesystem
instead of an indication to set the MS_BIND flag?

The full /etc/fstab is:

/dev/System/Root        /               ext3    user_xattr,acl,defaults 1 1
LABEL=/boot             /boot           ext3    defaults        1 2
/dev/Storage/Media      /mnt/storage    ext3    user_xattr,acl,defaults 1 1
none                    /dev/pts        devpts  gid=5,mode=620  0 0
none                    /dev/shm        tmpfs   defaults        0 0
none                    /proc           proc    defaults        0 0
none                    /sys            sysfs   defaults        0 0
/dev/System/Swap        swap            swap    defaults        0 0
/mnt/storage/nicholas/media /home/nicholas/media auto bind 0 0
/mnt/storage/nicholas/stuff /home/nicholas/stuff auto bind 0 0
Comment 3 Chris Lumens 2006-03-28 17:07:40 EST
When it hits the error message, can you switch over to tty2 and copy
/tmp/anaconda.log somewhere useful so you can attach it to this bug report? 
That should have something helpful in it.  My initial attempt to reproduce this
didn't show the bug, so I'll need to dig a little deeper.

If you comment out the first bind mount, does the second one work?
Comment 4 Nicholas Miell 2006-03-29 17:14:15 EST
Created attachment 127025 [details]
Anaconda log

It looks like Anaconda never mounted /mnt/storage (and the output of the mount
command confirms this), which means that /mnt/storage/nicholas/{media,stuff}
don't exist and can't be bind mounted to /home/nicholas/{media,stuff}.
Comment 5 Nicholas Miell 2006-03-29 17:15:57 EST
Hmm. Apparently attaching things to bugs doesn't kick it from NEEDINFO_REPORTER
to UNCONFIRMED. So here's a comment to do that.
Comment 6 Paul Howarth 2006-05-10 05:57:54 EDT
Is anaconda clever enough to remap /mnt/storage/nicholas/media to
/mnt/sysimage/mnt/storage/nicholas/media for bind mounts?
Comment 7 Paul Howarth 2006-05-10 11:17:18 EDT
(In reply to comment #5)
> Hmm. Apparently attaching things to bugs doesn't kick it from NEEDINFO_REPORTER
> to UNCONFIRMED. So here's a comment to do that.

Checking the "I am providing the requested information for this bug" box may be
what's needed, so I'll try that for you.
Comment 8 Nicholas Miell 2006-05-10 16:09:31 EDT
Whoops, never saw that checkbox. I'll try it too, the more the merrier.
Comment 9 Nicholas Miell 2006-05-17 02:42:48 EDT
Trying again...
Comment 10 Chris Lumens 2006-10-03 10:35:55 EDT
Closing due to lack of updates.  Please try again with FC6 and reopen this bug
if you are still seeing problems.
Comment 11 Paul Howarth 2006-10-03 10:48:33 EDT
(In reply to comment #10)
> Closing due to lack of updates.  Please try again with FC6 and reopen this bug
> if you are still seeing problems.

Lack of updates? Is the attachment in Comment #4 not what you asked for?
Comment 12 Chris Lumens 2006-10-03 10:52:17 EDT
I was closing due to the amount of time that has passed since comment #9, which
I took to mean that Nicholas was trying to reproduce it again.  If this is still
happening, feel free to reopen the bug.  Testing with FC6 would be especially
appreciated.
Comment 13 Paul Howarth 2006-10-03 11:16:58 EDT
OK; I have some bind-mounted ISO images on one of my machines. For FC5 I
commented them out of fstab prior to doing the upgrade. I'll give the FC6
upgrade a go without doing this to see what happens.
Comment 14 Nicholas Miell 2006-10-03 19:41:13 EDT
Comment #9 was in reference to this bug not transitioning out of NEEDINFO state
despite my reply and the checking of the "This responses contains the requested
information" checkbox. i.e. I was talking trying to get bugzilla to work, not
Anaconda (which was definitely still broken).

Note You need to log in before you can comment on or make changes to this bug.