Bug 18585 - GCC 2.96 included in Redhat 7.0 in error
Summary: GCC 2.96 included in Redhat 7.0 in error
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://gcc.gnu.org/ml/gcc-announce/20...
Whiteboard:
Keywords:
: 18558 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-07 03:20 UTC by tannhaus
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-07 03:20:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tannhaus 2000-10-07 03:20:10 UTC
Message from the gcc steering committee

http://gcc.gnu.org/ml/gcc-announce/2000/msg00003.html

Comment 1 Jakub Jelinek 2000-10-07 15:37:55 UTC
This gcc was not put into a distribution in error, but on purpose.
See http://www.lwn.net/2000/1005/a/rh-tools.php3 for explanation.
The fact that the Steering Commitee does not want to support this
compiler does not change anything on the fact that Red Hat is
supporting this compiler and we'll try to fix all bugs in it
which will be reported to us.
BTW: so far all bugs reported against our compiler were reproduceable
with vanilla FSF gcc as well.

Comment 2 Jakub Jelinek 2000-10-07 15:39:24 UTC
*** Bug 18558 has been marked as a duplicate of this bug. ***

Comment 3 Jacob Killian 2001-01-22 16:41:53 UTC
"Please note that both GCC 2.96 and 2.97 are development versions; we do not
recommend using them for production purposes.  Binaries built using any version
of GCC 2.96 or 2.97 will not be portable to systems based on one of our regular
releases."

-- http://gcc.gnu.org/gcc-2.96.html

Seems pretty clear to me.  Why RH would offer an OS as a stable, major, release
with a C compiler which comes with such a clear warning against using said
compiler in production environments, I do not know.  I would like to see a
better explaination, as well as some information on how RH plans to support gcc
3.0.


Note You need to log in before you can comment on or make changes to this bug.