Bug 185952 - clustat -s reports all services rather than just the specified one
Summary: clustat -s reports all services rather than just the specified one
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 180185
TreeView+ depends on / blocked
 
Reported: 2006-03-20 13:22 UTC by Nick Strugnell
Modified: 2009-04-16 20:20 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0557
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:22:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0557 normal SHIPPED_LIVE rgmanager bug fix update 2006-08-10 04:00:00 UTC

Description Nick Strugnell 2006-03-20 13:22:33 UTC
Description of problem:
clustat -s <service name> reports the status of all services rather than just
the specified one. This breaks scripts for clients upgrading from RHCS3.

Version-Release number of selected component (if applicable):
1.9.46-0

How reproducible:
always

Steps to Reproduce:
1. Install RHCS4 cluster with multiple services
2. Type "clustat -s <service name>"
3.
  
Actual results:
Status listing for all services

Expected results:
Status listing for specified service

Additional info:

Comment 2 Lon Hohberger 2006-03-20 20:57:58 UTC
definitely a bug

Comment 4 Lon Hohberger 2006-05-09 15:47:52 UTC
Let me know if this works for you.

Comment 8 Riaan van Niekerk 2006-07-06 10:06:38 UTC
works for me.
I tested on x86_64 (which is what I had access to.)


Comment 11 Red Hat Bugzilla 2006-08-10 21:22:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0557.html



Note You need to log in before you can comment on or make changes to this bug.