Bug 185995 - "Error connecting to xend: Connection refused" on FC5 x86_64
Summary: "Error connecting to xend: Connection refused" on FC5 x86_64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 185996 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-20 20:30 UTC by David Morse
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 21:56:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of boot on 2.6.15-1.1955_FC5hypervisor x86_64 (11.54 KB, text/plain)
2006-03-20 20:37 UTC, David Morse
no flags Details
xend.log showing the Connection refused error in detail (1.76 KB, text/plain)
2006-03-20 20:38 UTC, David Morse
no flags Details

Description David Morse 2006-03-20 20:30:26 UTC
Description of problem:

Doing an "xm list", I get "Error: Error connecting to xend: Connection 
refused.  Is xend running?".  /var/log/xend.log shows "Exception starting xend 
((111, 'Connection refused'))".  This same setup seemed to work fine on a 32-
bit FC5 install, so this may be x86_64 specific.


Version-Release number of selected component (if applicable):
2.6.15-1.1955_FC5hypervisor, xen-3.0.1-4

How reproducible: Every time

Steps to Reproduce:
1. Install FC5 on x86_64 machine, with "Xen" as a group
2. xm list
  
Actual results:
Error: Error connecting to xend: Connection refused.  Is xend running?

Expected results:
Should list dom0

Additional info:
I'll be attaching dmesg and xend-debug.log to this bug.  This occurred with 
test3 and the gold release of FC5.

Comment 1 David Morse 2006-03-20 20:33:55 UTC
*** Bug 185996 has been marked as a duplicate of this bug. ***

Comment 2 David Morse 2006-03-20 20:37:48 UTC
Created attachment 126362 [details]
dmesg of boot on 2.6.15-1.1955_FC5hypervisor x86_64

Comment 3 David Morse 2006-03-20 20:38:44 UTC
Created attachment 126363 [details]
xend.log showing the Connection refused error in detail

Comment 4 David Morse 2006-03-20 21:56:46 UTC
I used yum to upgrade test3 to gold, and noticed kernel-xen-hypervisor has been 
renamed kernel-xen0.  I installed kernel-xen0-2.6.15-1.2054_FC5 and xm list now 
works; closing this bug.


Note You need to log in before you can comment on or make changes to this bug.