This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185998 - Missing libraries prevent starting azureus
Missing libraries prevent starting azureus
Status: CLOSED DUPLICATE of bug 186152
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 15:40 EST by Christian Nolte
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-01 22:43:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2006-03-20 15:40:01 EST
Description of problem:

Azureus does not start, because of missing libs which are not found until adding
the path to the libs manually to LD_LIBRARY_PATH. The libs are
/usr/lib/libswt-pi-gtk-3139.so and /usr/lib/libglibjni-0.2.so.


Version-Release number of selected component (if applicable):
azureus-2.4.0.0-0.20060209cvs_1.fc5

How reproducible:
Start azureus via command-line to see the java backtraces and error messages.

Steps to Reproduce:
1. Start azureus via console
2. 
3.
  
Actual results:
Azureus does not start.

Expected results:
Azureus should start.


Additional info:
Executing "export LD_LIBRARY_PATH=/usr/lib/eclipse/:/usr/lib; azureus" solves
this problem for me.
Comment 1 Brian G. Anderson 2006-03-31 15:59:31 EST
Bug #186152 is the same as this one.  I suspect you are using java-sun correct?
Comment 2 Christian Nolte 2006-04-01 02:33:10 EST
Yes that is correct and an information I should have given you in the
firstplace... I can run azureus perfectly when I choose the GNU-VM as an
alternative. So this problem only occurs when using java-sun (jpackage.org).
Comment 3 Anthony Green 2006-04-01 22:43:47 EST

*** This bug has been marked as a duplicate of 186152 ***

Note You need to log in before you can comment on or make changes to this bug.