Bug 186007 - (NoEverything) "minimal" and "everything" install modes in FC5
"minimal" and "everything" install modes in FC5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
http://www.fedoraforum.org/forum/arch...
: FutureFeature, Reopened
: 186062 186802 191169 193243 199297 213685 221775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 17:42 EST by Razvan Sandu
Modified: 2008-01-24 11:06 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 18:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Razvan Sandu 2006-03-20 17:42:39 EST
Description of problem:

Anaconda doesn't provide a way to install Fedora Core 5 in:
- "minimal" mode - the minimum number of packages that are necessary for 
running;
- "everything" mode - all packages available on the installation CDs;

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Anaconda in FC5 should have the "minimal" and "everything" install options.


Additional info:
Comment 1 Chris Lumens 2006-03-21 09:54:34 EST
The minimal install option has been removed because we really need to make a
concerted effort to provide an actual minimal install, ideally requiring just
the first CD.  You can fake it by unselecting everything or doing a kickstart
installation with just @Base in the package section.

The everything button is gone, and will not be coming back.  It has become
increasingly difficult to maintain an everything install option, and will be
even more difficult in the future if multiple repositories are to be available
at install time.  See the extremely long discussions on fedora-devel-list,
fedora-test-list, and bug 183871 for more information.
Comment 2 Chris Lumens 2006-03-21 09:55:11 EST
*** Bug 186062 has been marked as a duplicate of this bug. ***
Comment 3 Paul Nasrat 2006-03-26 20:08:34 EST
*** Bug 186802 has been marked as a duplicate of this bug. ***
Comment 4 Razvan Sandu 2006-03-29 18:13:44 EST
Hello,

However, *I consider this to be a bug*, because the "minimal" and "everything"
buttons were *shortcuts* for doing installs.

IMHO, the "everything" install has nothing to do with Anaconda's ability of
using extern repositories. Please think of it as "everything install = all RPM
packages that are actually included on the CDs" (it's a well-delimited/defined
collection of packages, i.e. "the kit" on the physical media).


Regards,
Razvan
Comment 5 Paul Nasrat 2006-05-09 10:49:47 EDT
*** Bug 191169 has been marked as a duplicate of this bug. ***
Comment 6 Paul Nasrat 2006-05-26 12:21:09 EDT
*** Bug 193243 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2006-07-18 15:02:22 EDT
*** Bug 199297 has been marked as a duplicate of this bug. ***
Comment 8 Ian Pilcher 2006-07-19 12:49:03 EDT
A suggestion -- Rather than bringing "Minimal" and "Everything" back as
installation types, would it be possible to add a couple of buttons -- "Select
Everything" and "Unselect Everything" -- to the package selection screen?  It
might not be a bad idea to have a "Restore Defaults" button also.
Comment 9 Jeremy Katz 2006-07-19 18:28:23 EDT
These still leave things open to misinterpretation and don't really solve any of
the problems with the meanings of "everything" and "minimal".

Multiple selection in pirut will happen (so that you can select multiple groups
at once using standard GTK multiple selection), but a button is impossible to
have worded clearly enough. 
Comment 10 IBM Bug Proxy 2006-07-20 10:45:56 EDT
----- Additional Comments From bwthomas@us.ibm.com  2006-07-20 10:50 EDT -------
Before we fully close this, any comments on the search function also not being 
present?

I have no further issues on the everything install aspect. 
Comment 11 IBM Bug Proxy 2006-08-05 02:55:24 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From bugrobot@linux.ibm.com  2006-08-05 03:01 EDT -------
This bug has been automatically closed due to lack of activity.  Please reopen
if it is still valid. 
Comment 12 Bruno Wolff III 2006-10-28 16:14:45 EDT
Now that I have gone through mucho right clicking on my first practice FC6
install, I would like to suggest expanding the right click feature for selecting
optional pages to work at the top level groupings so that I only need to do 6
right clicks to select everything that can be during the install.
Comment 13 David Cantrell 2006-11-02 13:39:10 EST
*** Bug 213685 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2007-01-24 11:46:04 EST
*** Bug 221775 has been marked as a duplicate of this bug. ***
Comment 15 Chris Lumens 2008-01-24 11:06:11 EST
*** Bug 221775 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.