Bug 186010 - Installation of Errata RHBA-2006:0108-5 breaks 'ant'
Installation of Errata RHBA-2006:0108-5 breaks 'ant'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ant (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Deepak Bhole
:
: 186009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 18:15 EST by David Bennett
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 09:07:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bennett 2006-03-20 18:15:36 EST
Description of problem:

After updating the java-1.4.2-ibm to release 1jpp_13rh,  the 
'ant' command breaks with the following error:

  The java class is not found:  org/apache/tools/ant/launch/Launcher

Version-Release number of selected component (if applicable):

  ant-1.6.2-3jpp_3rh

How reproducible:

  ant

Steps to Reproduce:
1. log in
2. run ant --execdebug

  
Actual results:

exec "/usr/bin/java" -classpath "/usr/bin/build-classpath: error: 
JVM_LIBDIR /usr/lib/jvm-exports/java-1.4.2-ibm-1.4.2.2 does not exist or is 
not a directory" -Dant.home="/usr/share/ant" -
Dant.library.dir="/usr/share/ant/lib" org.apache.tools.ant.launch.Launcher -
lib ""
The java class is not found:  org/apache/tools/ant/launch/Launcher

Additional info:

It appears that the directory:

  /usr/lib/jvm-exports/java-1.4.2-ibm-1.4.2.2

Was replaced by:

  /usr/lib/jvm-exports/java-1.4.2-ibm-1.4.2.3
  
Issuing the following commands fixes the problem:

  cd /usr/lib/jvm-exports
  ln -s java-1.4.2-ibm-1.4.2.3 java-1.4.2-ibm-1.4.2.2
Comment 1 Thomas Fitzsimmons 2006-03-20 19:35:01 EST
Do you have both java-1.4.2-ibm and java-1.4.2-ibm-devel installed and set as
your alternatives?
Comment 2 David Bennett 2006-03-21 00:26:58 EST
# rpm -qa | grep 'java.*ibm'
java-1.4.2-ibm-jdbc-1.4.2.3-1jpp_13rh
java-1.4.2-ibm-devel-1.4.2.3-1jpp_13rh
java-1.4.2-ibm-src-1.4.2.3-1jpp_13rh
java-1.4.2-ibm-1.4.2.3-1jpp_13rh
java-1.4.1-ibm-1.4.1.2-1jpp_2rh
java-1.4.2-ibm-demo-1.4.2.3-1jpp_13rh
java-1.4.2-ibm-plugin-1.4.2.3-1jpp_13rh

# ls -l /etc/alternatives/java*
lrwxrwxrwx    1 root     root           48 Mar 17 
18:10 /etc/alternatives/java -> /usr/lib/jvm/java-1.4.2-ibm-
1.4.2.3/jre/bin/java
lrwxrwxrwx    1 root     root           45 Mar 17 
18:09 /etc/alternatives/javac -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3/bin/javac
lrwxrwxrwx    1 root     root           47 Mar 17 
18:09 /etc/alternatives/javadoc -> /usr/lib/jvm/java-1.4.2-ibm-
1.4.2.3/bin/javadoc
lrwxrwxrwx    1 root     root           45 Mar 17 
18:09 /etc/alternatives/javah -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3/bin/javah
lrwxrwxrwx    1 root     root           45 Mar 17 
18:09 /etc/alternatives/javap -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3/bin/javap
lrwxrwxrwx    1 root     root           35 Mar 17 
18:09 /etc/alternatives/java_sdk -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3
lrwxrwxrwx    1 root     root           35 Mar 17 
18:09 /etc/alternatives/java_sdk_1.4.2 -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3
lrwxrwxrwx    1 root     root           43 Mar 17 
18:09 /etc/alternatives/java_sdk_1.4.2_exports -> /usr/lib/jvm-exports/java-
1.4.2-ibm-1.4.2.3
lrwxrwxrwx    1 root     root           43 Mar 17 
18:09 /etc/alternatives/java_sdk_exports -> /usr/lib/jvm-exports/java-1.4.2-
ibm-1.4.2.3
lrwxrwxrwx    1 root     root           35 Mar 17 
18:09 /etc/alternatives/java_sdk_ibm -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.3
lrwxrwxrwx    1 root     root           43 Mar 17 
18:09 /etc/alternatives/java_sdk_ibm_exports -> /usr/lib/jvm-exports/java-
1.4.2-ibm-1.4.2.3
lrwxrwxrwx    1 root     root           46 Mar 17 
18:10 /etc/alternatives/javaws -> /usr/lib/jvm/java-1.4.2-ibm-
1.4.2.3/jre/javaws
Comment 3 David Bennett 2006-03-22 13:21:13 EST
Discovered the problem.  The standard rpm's do not define a JAVA_HOME 
in /etc/profile.d so I had created a /etc/profile.d/java.sh (and comparable 
csh) that read:

JAVA_HOME="/usr/lib/jvm/java-1.4.2-ibm-1.4.2.3"
PATH=$JAVA_HOME:$PATH
export PATH JAVA_HOME

I have changed this to the symlink:

JAVA_HOME="/usr/lib/jvm/java"
PATH=$JAVA_HOME:$PATH
export PATH JAVA_HOME

Which should solve the problem.  It would be nice if the rpm installation 
included a /etc/profile.d script.

You can CLOSE this.

Comment 4 Thomas Fitzsimmons 2006-03-22 13:38:09 EST
The JPackage conventions were designed to eliminate the need to set PATH and
JAVA_HOME.  Why are you setting them at all?
Comment 5 Deepak Bhole 2006-05-31 18:05:55 EDT
*** Bug 186009 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.