Bug 186016 - Xorg i810 server freeze: "INVALID MEM ALLOCATION"
Xorg i810 server freeze: "INVALID MEM ALLOCATION"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 19:35 EST by Ian Kluft
Modified: 2012-05-04 01:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 10:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to implement temporary workaround from freedesktop.org (663 bytes, patch)
2006-03-20 19:35 EST, Ian Kluft
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5443 None None None Never

  None (edit)
Description Ian Kluft 2006-03-20 19:35:41 EST
Description of problem:

XOrg server using i810 freezes and won't release console.

Version-Release number of selected component (if applicable):

FC5 xorg-x11-server-Xorg-1.0.1-9

How reproducible: every time



Steps to Reproduce:
1. start X on FC5 on laptop using i810 driver.
2. screen freezes or blanks.
  
Actual results:

CTRL-ALT-BACKSPACE, other keys, "kill", "kill -9" do not release console.

Server log reports "INVALID MEM ALLOCATION".  Many user logs were submitted at
freedesktop.org.

Expected results:

X should start

Additional info:

This problem has been identified and a workaround found on
https://bugs.freedesktop.org/show_bug.cgi?id=5443

I patched the FC5 rpms to include the workaround at
http://sw.sbay.org/fc5/i810-video-workaround-20060320/ (patch file with
one-liner change attached)

As noted by a commenter on the freedesktop.org bugzilla, this is a workaround,
not a fix.  It comments out a call to ValidatePCI() in the core server, which is
"invasive" (as the commenter over there says.)  However, this worked for me,
making the difference between "doesn't work at all" and "seems to work fine so
far."  So I consider it important information in helping you diagnose the real
problem.
Comment 1 Ian Kluft 2006-03-20 19:35:42 EST
Created attachment 126370 [details]
patch to implement temporary workaround from freedesktop.org
Comment 2 Hyun-Jin Moon 2006-05-15 22:23:59 EDT
I am also suffering same problem. Because anaconda had been freeze I could even
install FC5 from FC5 CD. I installed FC4 and updated to FC5 using yum. Now I
used vesa driver.
Comment 3 Mike A. Harris 2006-06-27 10:47:42 EDT
The upstream bug above has been marked as a duplicate of
https://bugs.freedesktop.org/show_bug.cgi?id=6750 which has been closed
now as fixed in X11R7.1

There is also indication that this is actually a hardware bug, and that the
"fix" is a workaround for that hardware bug.

Closing bug as "RAWHIDE" as we have 7.1 in rawhide currently, however we
are also planning on releasing it as an FC5 update in the future.

Note You need to log in before you can comment on or make changes to this bug.