Bug 186017 - RHEL4: Top "Cpu0" line never updates when using "Single Cpu = Off" option on single processor machine
RHEL4: Top "Cpu0" line never updates when using "Single Cpu = Off" option on ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2006-03-20 20:05 EST by Karel Zak
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0365
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 18:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2006-03-20 20:05:15 EST
+++ This bug was initially created as a clone of Bug #185994 +++

By default, top displays a CPU usage summary for all CPUs on a single line, e.g.:

Cpu(s):  1.0% us,  0.0% sy,  0.0% ni, 99.0% id,  0.0% wa,  0.0% hi,  0.0% si

Pressing "1" changes this to display separate lines for each CPU, e.g. for a
single processor machine:

Cpu0  : 12.2% us,  3.2% sy,  0.0% ni, 84.7% id,  0.0% wa,  0.0% hi,  0.0% si

The problem is that on non-SMP boxes the top never updates this Cpu0 line.

-- Additional comment from kzak@redhat.com on 2006-03-20 19:53 EST --
Ah.. you're right. Nobody complains probably because nobody on non-SMP uses
"list of CPUs" :-)

-- Additional comment from kzak@redhat.com on 2006-03-20 20:00 EST --
BTW, I think this problem is valid for all 3.x procps versions and probably
exists pretty long time. Good catch!
Comment 6 Red Hat Bugzilla 2006-05-10 18:06:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0365.html

Note You need to log in before you can comment on or make changes to this bug.