Bug 186021 - FC5 Installer does not recognize BusLogic (vmware) SCSI adapter
Summary: FC5 Installer does not recognize BusLogic (vmware) SCSI adapter
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 186185 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-21 02:29 UTC by Josh Burke
Modified: 2015-01-04 22:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 20:48:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LSPCI output when installer at stage "select partitions to use" (2.35 KB, text/plain)
2006-03-21 02:29 UTC, Josh Burke
no flags Details
dmesg output (7.52 KB, text/plain)
2006-03-21 02:31 UTC, Josh Burke
no flags Details

Description Josh Burke 2006-03-21 02:29:17 UTC
Greetings,

Attempting to update FC4 -> FC5 on a VMware guest.  (vmware workstation #
5.5.1-19175) From CDs, verified good.

My system under FC4 has three drives -- two BusLogic SCSI, and one ide.  The IDE
drive is detected by the installer, but the SCSI drives are not.

Only the IDE drive is given as an option for installation -- FC4 install worked
fine.

This may be related to Bugzilla # 182298 -- same symptoms.  Setting pci=noacpi
does not fix my issue, though.

Thanks!

Comment 1 Josh Burke 2006-03-21 02:29:17 UTC
Created attachment 126371 [details]
LSPCI output when installer at stage "select partitions to use"

Comment 2 Josh Burke 2006-03-21 02:31:06 UTC
Created attachment 126372 [details]
dmesg output

Comment 3 Jeremy Katz 2006-03-21 16:43:34 UTC
The buslogic module isn't exporting any pci ids as supported, so we don't know
to load it.  If you boot with 'linux noprobe', you should be able to manually
load the buslogic driver.

Comment 4 Josh Burke 2006-03-21 17:51:02 UTC
Manually loading the driver with 'linux noprobe' now shows all partitions. 
Thanks.  

Comment 5 Dave Jones 2006-03-21 19:28:59 UTC
buslogic is unmaintained upstream.  vmware has an option to emulate either
buslogic or mpt fusion.  The fusion driver is actively maintained, and should work.


Comment 6 Jeremy Katz 2006-03-22 01:45:40 UTC
*** Bug 186185 has been marked as a duplicate of this bug. ***

Comment 7 Josh Burke 2006-03-22 01:49:53 UTC
Link to VMWare fix for this bug: (changing from BusLogic to lsilogic, this works
in Workstation 5.5 in addition to the versions listed by VMWare)

http://www.vmware.com/support/kb/enduser/std_adp.php?&p_faqid=1216


Note You need to log in before you can comment on or make changes to this bug.