This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 186036 - GTK java-binding broken
GTK java-binding broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgtk-java (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Igor Foox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 02:49 EST by Tomi Malkki
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 05:20:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Example application (756 bytes, text/plain)
2006-03-21 02:49 EST, Tomi Malkki
no flags Details
Example applications glade file (2.66 KB, text/plain)
2006-03-21 02:51 EST, Tomi Malkki
no flags Details

  None (edit)
Description Tomi Malkki 2006-03-21 02:49:40 EST
Created attachment 126377 [details]
Example application
Comment 1 Tomi Malkki 2006-03-21 02:49:40 EST
I made simple java gtk-software and got it compiled. When I try to run it, it
fails. Tryed on Fedora Core 4, and it worked on it.

Compiled with: javac -classpath
/usr/share/java/gtk2.8.jar:/usr/share/java/glade2.12.jar Main.java

Runned with: java --classpath
/usr/share/java/gtk2.8.jar:/usr/share/java/glade2.12.jar:. Main
java --classpath
/usr/share/java/gtk2.8-2.8.3.0.20060301.rh1.jar:/usr/share/java/glade2.12-2.12.2.0.20060301.rh1.jar:.
org.manet.Main

Error message when runned: 
Exception in thread "main" java.lang.NoClassDefFoundError: org.gnu.gtk.Gtk
   at java.lang.Class.initializeClass (libgcj.so.7)
   at Main.main (Main.java:28)
Caused by: java.lang.ClassNotFoundException: org.gnu.glib.Struct not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/gtk2.8.jar,file:/usr/share/java/glade2.12.jar,file:./],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass (libgcj.so.7)
   at java.lang.ClassLoader.loadClass (libgcj.so.7)
   at java.lang.ClassLoader.loadClass (libgcj.so.7)
   at java.lang.Class.forName (libgcj.so.7)
   at java.lang.Class.initializeClass (libgcj.so.7)
   ...1 more
Comment 2 Tomi Malkki 2006-03-21 02:51:29 EST
Created attachment 126378 [details]
Example applications glade file

Note You need to log in before you can comment on or make changes to this bug.