Bug 186094 - Non-ascii characters appear as garbage in XTerm title
Non-ascii characters appear as garbage in XTerm title
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 11:34 EST by Daniel Qarras
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 11:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2006-03-21 11:34:10 EST
Description of problem:
XTerm title in FC5 shows the current working directory. This works ok with ASCII
characters. But when starting XTerm under GNOME in FC5 and going to a directory
that names has non-ascii characters, the title is garbage (escape sequences).

Version-Release number of selected component (if applicable):
xterm-209-4

How reproducible:
Always.

Steps to Reproduce:
1. Start XTerm
2. Create directory named üö
3. Enter the directory
  
Actual results:
Escape sequences are shown in the XTerm title instead of the actual characters.

Expected results:
The proper characters should be shown in the XTerm title.

Additional info:
gnome-terminal works all ok. Using bash as shell. Fresh installation with
default values.
Comment 1 Jason Vas Dias 2006-03-21 17:51:02 EST
Yes, xterm-211 now has the 'UTF-8 Titles' menu item and the 'utf8Title' vt100 X
resource to enable display of UTF-8 titles (no previous xterm version did this).
Since we ship with UTF-8 enabled locales by default, I guess this resource
should be set by default in the Red Hat distributions.
I've submitted xterm-211 with the VT100*ut8Title resource enabled by default
to FC-5 Updates/Testing .

Comment 2 Fedora Update System 2006-03-21 18:06:12 EST
xterm-211-1.FC5 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Daniel Qarras 2006-03-22 03:38:42 EST
I can confirm that the problem is fixed with xterm-211-1.FC5. Thanks!
Comment 4 Fedora Update System 2006-03-27 11:53:02 EST
xterm-211-1.FC5 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2006-04-17 11:40:33 EDT
xterm-212-1.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-05-03 14:50:59 EDT
xterm-212-1.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.