Bug 186135 - NetworkManager does not do anything with a recently inserted Netgear WG511
NetworkManager does not do anything with a recently inserted Netgear WG511
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 15:33 EST by Suzanne Hillman
Modified: 2008-03-10 21:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: Fedora 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 21:59:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Results from when the Netgear was correclty noticed and IDed. (2.42 KB, text/plain)
2006-03-21 15:33 EST, Suzanne Hillman
no flags Details
udev work-around (252 bytes, text/plain)
2006-09-18 00:31 EDT, Philippe Troin
no flags Details

  None (edit)
Description Suzanne Hillman 2006-03-21 15:33:57 EST
Description of problem:
NetworkManager does not do anything with a recently inserted Netgear WG511. This
worked on another machine which had been installed with rawhide (pre-release
FC5) from a week and a half ago, and disabling selinux on the FC5 Gold machine
did not help.

I am currently checking to see if upgrading the pre-release FC5 box to FC5 Gold
causes it to no longer be able to do anything with the Netgear card in question. 

Version-Release number of selected component (if applicable):
NetworkManager-0.6.0-3
(the version on the pre-release box was apparently 0.6.0-2)

How reproducible:
Always.

Steps to Reproduce:
1. Obtain a laptop with FC5 Gold on it (this is a Sony Vaio)
2. Insert the Netgear WG511 into the PCMCIA slot
3. See the card get detected in /var/log/messages, but see nothing else happen;
no messages from the kernel saying that it figured out what kind of card it was
(and loaded the firmware and prism driver appropriately), none at all from
NetworkManager (this may belong as a kernel bug, since there were no kernel
messages; not sure)
  
Actual results:
No card being used in NetworkManager

Expected results:
Should be able to see wireless now listed as an option in NetworkManager

Additional info:
/var/log/messages says the following when the card is inserted (note no messages
from kernel specifying that the card type was recognized, and nothing at all
from NetworkManager):

Mar 21 15:18:23 dhcp83-71 kernel: pccard: CardBus card inserted into slot 0
Mar 21 15:18:23 dhcp83-71 kernel: PCI: Enabling device 0000:07:00.0 (0000 ->
0002)
Mar 21 15:18:23 dhcp83-71 kernel: ACPI: PCI Interrupt 0000:07:00.0[A] -> GSI
16 (level, low) -> IRQ 16

Since I'm suspecting kernel, although not strongly enough to put this as kernel
instead of NetworkManager, I note that it looks like the pre-release machine had
kernel-2.6.15-1.2032_FC5, and GOLD has kernel-2.6.15-1.2054_FC5.

Will attach the results of a successful recognition of this card to this bug report.

Also, upgrading did not break it, at least on the one machine I tried it on.
This could either be a result of upgrading really not breaking things, or
because it's a different laptop, unfortunately... (the laptop on which things
worked both before and after upgrade is an Acer Aspire)
Comment 1 Suzanne Hillman 2006-03-21 15:33:59 EST
Created attachment 126429 [details]
Results from when the Netgear was correclty noticed and IDed.
Comment 2 Suzanne Hillman 2006-03-21 16:57:18 EST
Tried a fresh install on the Acer Aspire, which had been happy with previous to
release FC5, and note that it also did not check for firmware or any of the
other stuff, but _did_ say that it loaded driver (likely the other did, too, but
only the first time I inserted it). So this is not specific to the one laptop,
but is specific to fresh install vs upgrade.
Comment 3 Jeff Gustafson 2006-04-13 14:21:26 EDT
I too am having this problem.  In FC4 when I inserted the prism card
NetworkManager would detect the card and setup a list of available networks. 
With FC5 I have to restart NetworkManager to get this behavior.  It seems that
NetworkManager is not getting notified that the card was inserted.  Why?
Comment 4 Jason McBrayer 2006-05-30 14:12:12 EDT
I am also having this problem, both with my pcmcia ethernet card (uses 3c589_cs)
and my pcmcia wireless card (uses atmel_cs).  Both worked under FC4.  Now,
neither card is detected until after a restart of NetworkManager.  It also
appears to not detect the removal of a card until Networkmanager is restarted. 
I wonder if this has something to do with the change from pcmcia_cs to pcmciautils?
Comment 5 Philippe Troin 2006-09-18 00:31:27 EDT
Created attachment 136504 [details]
udev work-around

This is a work-around for the problem.
Download the attachment, and put it in /etc/udev/rules.d/99-laptop.rules
It restarts NetworkManager automatically whenever a new interface appears or
disappears.
-Phil.
Comment 6 Dan Williams 2007-10-31 22:52:25 EDT
Anyone still having these problems?  If you are, please attach the output of
'lshal'.  Thanks!
Comment 7 Philippe Troin 2007-11-27 16:57:40 EST
It works on F8 now.
Phil.

Note You need to log in before you can comment on or make changes to this bug.