Bug 186138 - make temporary dir specifiable?
make temporary dir specifiable?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Frank Ch. Eigler
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 15:44 EST by Bill Nottingham
Modified: 2015-01-07 19:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 12:00:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 1341 None None None Never

  None (edit)
Description Bill Nottingham 2006-03-21 15:44:04 EST
Description of problem:

The temporary directory is hardcoded as /tmp/stap<mkdtemp>.

It could be nice to have it specifiable (so you don't have to parse
the command output to find it with -k, or because you just want
to write it somewhere else.)

Arguably, it should honor TMPDIR, as gcc does.

Version-Release number of selected component (if applicable):

0.5.4-2.2
Comment 1 Frank Ch. Eigler 2006-03-21 15:46:53 EST
Already tracked on systemtap bugzilla.
Comment 2 Frank Ch. Eigler 2006-06-15 12:00:00 EDT
TMPDIR is now respected in the 0.5.7 build.

Note You need to log in before you can comment on or make changes to this bug.