Bug 186140 - XML_RPC server does not work
XML_RPC server does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 15:46 EST by Steve Fox
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: php-pear.noarch 1:1.4.6-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 22:51:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2006-03-21 15:46:15 EST
Description of problem:

The XLM_RPC PEAR package shipped by FC5 does not work with the version of PHP
shipped due to some header problems. XML_RPC 1.4.5 was released in PEAR to fix
this problem (see changelog at http://pear.php.net/package/XML_RPC/download/). A
manual upgrade fixes this problem.

Version-Release number of selected component (if applicable): php-pear-1.4.6-2


How reproducible: always


Steps to Reproduce:
1. Try sample scripts from XML_RPC documentation
2.
3.
  
Actual results:

<br />
<b>Warning</b>:  Header may not contain more than a single header, new line
detected. in <b>/usr/share/pear/XML/RPC/Server.php</b> on line <b>394</b><br />
<?xml version="1.0" encoding="UTF-8"?>
<methodResponse>
<params>
<param>
<value><int>16</int></value>
</param>
</params>
</methodResponse>
---END---</pre>
XML error: Invalid document end at line 2
Fault Code: 2
Fault Reason: Invalid return payload: enable debugging to examine incoming payload


Expected results:

8 times 2 is 16

Additional info:
Comment 1 Joe Orton 2006-03-22 10:16:57 EST
Thanks for the report; the update to 1.4.5 is on its way.
Comment 2 Fedora Update System 2006-03-22 14:38:39 EST
php-pear-1.4.6-2.1 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Steve Fox 2006-03-22 22:51:24 EST
Incredible response time. Thanks! Fix confirmed.

Note You need to log in before you can comment on or make changes to this bug.