Bug 186161 - arpwatch unable to send emails
arpwatch unable to send emails
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcpdump (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 17:31 EST by Stephen John Smoogen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 02:36:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2006-03-21 17:31:46 EST
Description of problem:

arpwatch out of the box is unable to send out emails. Not sure why it does not
as it seems to be similar to FC3 and FC4 working systems.

Problem is seen in RHEL-4 U2 and RHEL-4 U3...

SYSERR(pcap): can not chdir(/var/spool/mqueue): Permission denied

This may be the reason that the packetknife person was having problems with
RHEL-4 last summer. I dont remember having to do any other changes.
Comment 1 Martin Stransky 2006-03-28 08:23:01 EST
I've just checked RHEL4-U3 and it works fine out-of-the-box...
Comment 2 Martin Stransky 2006-03-28 08:24:50 EST
Does your mail-system work properly?
Comment 3 Stephen John Smoogen 2006-03-28 09:55:26 EST
Going to check. I have selinux turned on, and audit turned on so I forgot to
look in the audit logs to see what selinux warnings might occur. 
Comment 4 Stephen John Smoogen 2006-03-28 11:18:06 EST
Ok, I truely apologize on this one. The problem is due to 2 sysadmins doing the
same job and one not letting the other know it. An old submit.cf was placed on
the server which used /var/spool/mqueue and not /var/spool/clientmqueue. 

When I sent the test emails after install the correct clientmqueue was on the
box.. when I started arpwatch it wasnt.. I am such an idiot for not looking
there again.
Comment 5 Stephen John Smoogen 2006-03-28 11:19:09 EST
Cant close the ticket.. bugzilla says I dont have priv's to do so.

Note You need to log in before you can comment on or make changes to this bug.