Bug 186162 - DRI not working after I upgrade to FC5 final with Radeon Mobility 9100IGP
DRI not working after I upgrade to FC5 final with Radeon Mobility 9100IGP
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 17:38 EST by Luis Santos
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 12:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xserver log file (134.00 KB, text/plain)
2006-03-21 17:38 EST, Luis Santos
no flags Details
lsmod output (2.60 KB, text/plain)
2006-03-25 14:07 EST, Luis Santos
no flags Details

  None (edit)
Description Luis Santos 2006-03-21 17:38:26 EST
Description of problem:
After i upgraded to FC5 final DRI stoped working.
I already worked with my card but now it's not working. I did many tests and
aparently everything is correct.
I have never had problems with FC4.

Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1.
2.
3.
  
Actual results:
DRI not working

Expected results:


Additional info:
-------------------------------------------
[santos@c-217-70-64-18 ~]$ dmesg | grep agp
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected Ati IGP9100/M chipset
agpgart: AGP aperture is 32M @ 0xf6000000
[santos@c-217-70-64-18 ~]$ dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
Comment 1 Luis Santos 2006-03-21 17:38:26 EST
Created attachment 126441 [details]
xserver log file
Comment 2 Luis Santos 2006-03-21 17:40:00 EST
[santos@c-217-70-64-18 ~]$ uname -r
2.6.15-1.2054_FC5smp
Comment 3 Adam Goode 2006-03-21 19:43:41 EST
I saw this today. An strace of glxinfo seems to suggest that glxinfo is looking
for the r200 file in /usr/X11R6/..., not /usr/lib/... as it should.
Comment 4 Luis Santos 2006-03-22 08:47:19 EST
[root@c-217-70-64-18 santos]# glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_texture_from_drawable,
    GLX_MESA_allocate_memory, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_visual_select_group
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.2)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
    GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap,
    GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
    GL_HP_occlusion_test, GL_IBM_texture_mirrored_repeat,
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
    GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
    GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
    GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x24 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x25 16 tc  0 24  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x26 16 tc  0 24  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x27 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x28 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x29 16 dc  0 24  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x2a 16 dc  0 24  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
Comment 5 Adam Goode 2006-03-22 09:59:38 EST
Hmm, is this related to 

http://www.redhat.com/archives/fedora-devel-list/2006-February/msg01178.html

?
Comment 6 Luis Santos 2006-03-22 19:59:36 EST
I can not be 100% sure but i thing not.
I already have run a "rpm -Va" command and everything seems ok, having no
problems  with packages. I never installed ATI proprietary drivers because until
now i always have good speeds in 3d, for example in ppracer. I used to play
that. Now is    impossible to play torcs or ppracer.  

I forgot to say that my instalation was a result of a upgrade from FC4.

I did a experience. Removed everyting from "/usr/lib/dri" and restartd Xorg.
Xorg started normaly (without DRI)and logs did not indicated any file missing. 

Also i'm not sure if kernel part of DRM is ok. Is this message from boot log normal?
[santos@c-217-70-64-18 ~]$ dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102



Comment 7 Mike A. Harris 2006-03-23 22:55:10 EST
(In reply to comment #3)
> I saw this today. An strace of glxinfo seems to suggest that glxinfo is looking
> for the r200 file in /usr/X11R6/..., not /usr/lib/... as it should.

The Red Hat Mesa libGL supplied with Fedora Core has been manually tested
and confirmed to be looking in the correct place for the DRI drivers. Anyone
who is finding libGL looking in some other location such as /usr/X11R6, has
got an old copy of libGL around, or an incompatible libGL being found first
in the dynamic linker's search path.  Remove all other libGLs from your
OS installation, or reformat and do a fresh OS install, and the Red Hat
supplied libGL will be the one getting used, and it looks in the proper
place for the DRI modules.
Comment 8 Mike A. Harris 2006-03-23 23:04:03 EST
(In reply to comment #6)
> I can not be 100% sure but i thing not.
> I already have run a "rpm -Va" command and everything seems ok, having no
> problems  with packages. I never installed ATI proprietary drivers because until
> now i always have good speeds in 3d, for example in ppracer. I used to play
> that. Now is    impossible to play torcs or ppracer.  
> 
> I forgot to say that my instalation was a result of a upgrade from FC4.

Upgrades from FC4 should work fine.
 
> I did a experience. Removed everyting from "/usr/lib/dri" and restartd Xorg.

That is where the Mesa DRI 3D drivers are installed.  If you removed them,
then of course DRI is not going to work because the DRI drivers are no longer
installed.

Reinstall all of the mesa packages that come with FC5 to restore the files
properly.

> Xorg started normaly (without DRI)and logs did not indicated any file missing. 

The X server does not load the 3D drivers, so it will not ever indicate if
they are missing.  When you run an OpenGL application, it is linked to
libGL, and it is libGL that opens the 3D driver, which runs in the
application's memory space.

> Also i'm not sure if kernel part of DRM is ok. Is this message from boot log
normal?
> [santos@c-217-70-64-18 ~]$ dmesg | grep drm
> [drm] Initialized drm 1.0.1 20051102

When the X server's "dri" module is loaded, that loads the DRI extension
and if the kernel DRM is not loaded, it will be loaded when the 2D driver
starts up, unless DRI is disabled.  It appears also that the DRM will be
loaded even if DRI is disabled in some cases.



drmOpenDevice: node name is /dev/dri/card254
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
(II) RADEON(0): [drm] drmOpen failed
(EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.

This indicates that the DRI devices are inaccessible to the X server.

It looks on the surface like you might have multiple copies of libGL
installed also, and an incompatible libGL is causing conflicts. Please
ensure you do not have any other libGL installed anywhere on your system,
other than the libGL supplied in FC5 Mesa packaging.

Comment 9 Luis Santos 2006-03-25 14:06:19 EST
In other computer were DRI is working correctly (with i810) i see 3 messages
about  drm.
***********************************************
[santos@santos ~]$ dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized i810 1.4.0 20030605 on minor 0
[drm] Using v1.4 init.
***********************************************

In mine computer o only see one message about drm.

Some tests i did abour libs:

***********************************************
[root@c-217-70-64-18 /]# find / -name '*libGL*'
/usr/lib/libGLU.so.1
/usr/lib/libGLw.so
/usr/lib/libGLw.so.1
/usr/lib/xorg/modules/extensions/libGLcore.so
/usr/lib/libGL.so.1
/usr/lib/libGLw.so.1.0.0
/usr/lib/libGLU.so.1.3.060402
/usr/lib/libGL.so.1.2
[root@c-217-70-64-18 /]# rpm -q --file /usr/lib/libGL.so.1
mesa-libGL-6.4.2-6
[root@c-217-70-64-18 /]# rpm -V mesa-libGL
[root@c-217-70-64-18 /]# rpm -q --file /usr/lib/libGL.so.1.2
mesa-libGL-6.4.2-6
[root@c-217-70-64-18 /]# rpm -q --file /usr/lib/xorg/modules/extensions/libGLcore.so
xorg-x11-server-Xorg-1.0.1-9
[root@c-217-70-64-18 /]# rpm -V xorg-x11-server-Xorg
***********************************************

Atached i included lsmod. We can see radeon module is loaded but not in use.
Should't radeon module automaticaly generate a /dev/dri/card0 entry. Is there
any form i can use to debug radeon module? Can it be a problem with udev package
not automaticaly creating /dev/dri/* entrys?
Comment 10 Luis Santos 2006-03-25 14:07:22 EST
Created attachment 126738 [details]
lsmod output
Comment 11 Luis Santos 2006-03-25 20:15:09 EST
As we can see, glxgears is looking libs in correct locations

******************************************************
[root@c-217-70-64-18 /]# ldd /usr/bin/glxgears
        linux-gate.so.1 =>  (0x00970000)
        libglut.so.3 => /usr/lib/libglut.so.3 (0x00c39000)
        libGLU.so.1 => /usr/lib/libGLU.so.1 (0x008cc000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x00869000)
        libm.so.6 => /lib/libm.so.6 (0x00ac3000)
        libc.so.6 => /lib/libc.so.6 (0x0098e000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00afd000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00c11000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x007f3000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x02fe3000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x02c96000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00c23000)
        libdl.so.2 => /lib/libdl.so.2 (0x00aea000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0x007fa000)
        /lib/ld-linux.so.2 (0x00971000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00af0000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00af5000)

******************************************************
Comment 12 Luis Santos 2006-03-26 16:32:45 EST
Some more information:

When i activate debug in drm kernel module (echo 1 >
/sys/module/drm/parameters/debug) and after that unload and load radeon module
and after that restart X this is what i get in dmesg:
**********************************
[drm:drm_init]
[drm:drm_stub_open]
[drm:drm_stub_open]
[drm:drm_stub_open]
[drm:drm_stub_open]
**********************************

Please note that i do not unload drm module, only radeon soo this messages are
printed when radeon module is loaded or when X is loaded.
Comment 13 Luis Santos 2006-03-27 16:18:19 EST
I tried with one of last versions of kernel of fedora 4 and now DRI activates:
Here are some infos:
**************************************
[santos@c-217-70-64-18 ~]$ uname -r
2.6.15-1.1831_FC4

[santos@c-217-70-64-18 ~]$ dmesg  | grep agp
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected Ati IGP9100/M chipset
agpgart: AGP aperture is 32M @ 0xf6000000
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:05.0 into 4x mode

[santos@c-217-70-64-18 ~]$ dmesg  | grep drm
[drm] Initialized drm 1.0.0 20040925
[drm] Initialized radeon 1.19.0 20050911 on minor 0:
[drm] Loading R200 Microcode
**********************************************
can it be a agpart module problem?
Comment 14 Thomas Steudten 2006-04-05 13:38:39 EDT
Same problem with ATI Mobile X600 from scanpci:
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1002 device 0x3150
 ATI Technologies Inc M24 1P [Radeon Mobility X600]

a) kernel-2.6.16-1.2080_FC5
   The DRI is disabled here. So DRI doesn't work.
b) if I enable it (disable patch in kernel-2.6.spec), the Xorg server
   crashes the system if "load dri" is enabled.
   dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized radeon 1.22.0 20051229 on minor 0


Comment 15 Thomas Steudten 2006-04-05 13:41:55 EDT
Same problem with ATI Mobile X600 from scanpci:
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1002 device 0x3150
 ATI Technologies Inc M24 1P [Radeon Mobility X600]

a) kernel-2.6.16-1.2080_FC5
   The DRI is disabled here. So DRI doesn't work.
b) if I enable it (disable patch in kernel-2.6.spec), the Xorg server
   crashes the system if "load dri" is enabled.
   dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized radeon 1.22.0 20051229 on minor 0
Comment 16 Andy Burns 2006-04-06 08:42:21 EDT
(In reply to comment #15)

> Same problem with ATI Mobile X600 from scanpci:

I don't know if you want to stay with FC5 release or are willing to move to rawhide?

I have an X550 and today's rawhide appears to *load* all the DRI/DRM/GL
components for the first time on this card, it doesn't actually *function y*,
but it seems to be getting close FYI.

see thread
https://www.redhat.com/archives/fedora-devel-list/2006-April/msg00383.html

Comment 17 Thomas Steudten 2006-04-06 08:55:14 EDT
When I see what doesn't work correct anymore after update from FC4 to FC5, I'll
think about it. However, the most new problems come from the XOrg V7.0.. 
"Never change a running system" is more valid today ;-)
Comment 18 Thomas Steudten 2006-04-07 04:07:57 EDT
(In reply to comment #16)

Well, from your comment in the thread list below, I see that you've no "DRI",
means indirect and SW (Mesa) GLX, like me with FC5 and Xorg 7.0. Can you provide
your xorg.conf and the output from the Xorg server (/var/log/Xorg.log).
There's no 2d and no 3d HW acceleration from the graphic board for me right now:

        *** Direct rendering support is highly experimental for Radeon 9500
        *** and newer cards. The 3d mesa driver is not provided in this tree.
        *** A very experimental (and incomplete) version is available from Mesa CVS.
        *** Additional information can be found on http://r300.sourceforge.net
        *** This message has been last modified on 2005-08-07.

(II) RADEON(0): Depth moves disabled by default
(II) RADEON(0): Memory manager initialized to (0,0) (1408,8191)
(II) RADEON(0): Reserved area from (0,1050) to (1408,1052)
(II) RADEON(0): Largest offscreen area available: 1408 x 7139
(II) RADEON(0): Render acceleration unsupported on Radeon 9500/9700 and newer.
(II) RADEON(0): Render acceleration disabled
(II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)
(WW) RADEON(0): Direct rendering disabled

Starting only the XOrg server (with "Xorg") and glxgears or xengine, gives for me:
glxgears:
1000 frames in 5.8 seconds = 172.217 FPS
875 frames in 5.1 seconds = 173.038 FPS
xengine: 1616 Upm

That's quiet slow.

When I disable the r300 remove-patch from the 2.6.16-2080 kernel, I can load the
radeon DRI kernel driver:
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized radeon 1.22.0 20051229 on minor 0

But if I try to start the Xorg server with "Load DRI" enabled, the system
freezes! Without the "Load DRI" entry in xorg.conf, I get the results given
before with glxgears and xengine.
With FC4 xengine gives 15000 Upm, glxengine like the same with FC5.

So, what is still open is:
1) Working DRI in 2.6.16 kernel (maybe this is there)
2) Working Xorg 7.0 with DRI
3) HW acceleration for 2D and 3D with ATI radeon X600 M24 PCIE chip.

For the latter on ATI offers a drivers, but the Xorg 6.9.0 installer fails to
build a RPM package with this "Copyright" instead of "License" change, and the
given 6.8.0 rpm package from ATI has some undefined modules references.

> I don't know if you want to stay with FC5 release or are willing to move to
rawhide?
> 
> I have an X550 and today's rawhide appears to *load* all the DRI/DRM/GL
> components for the first time on this card, it doesn't actually *function y*,
> but it seems to be getting close FYI.
> 
> see thread
> https://www.redhat.com/archives/fedora-devel-list/2006-April/msg00383.html
> 
> 

Comment 19 Thomas Steudten 2006-04-07 04:37:44 EDT
With my X600 M24 PCIE in laptop I can load the radeon kernel driver and this
looks good. With "load dri" in xorg.conf I can start the Xorg 7.0 server with
"Xorg -probeonly" and this looks good too. But without the "-probeonly" the
system hangs. I tried to disable some values in the xorg.conf, but always a
system freeze with DRM/DRI. BTW: I've no settings in the BIOS for graphic.

Let me know, if I can offer more tests or details. 
Comment 20 Thomas Steudten 2006-04-12 09:32:10 EDT
With the development package from FC5 and ati package, the DRI/DRM works for me.
But the DRM from kernel needs to be updated from version 1.22 to 1.23 to use the
full memory range (from the Xorg.log). The DRM should be enabled in the kernel
for this card: X600 M24 PCIE Device ID 0x3150 - in kernel -2080 this is disabled!).
Xengine gives now 12000 Upm, instead of 1500 Upm.

Still open problems:
a) Icons from the BIOS (like brightness, battery status in the left-uppper
corner is broken, not with xorg 6.8.2)
Comment 21 Thomas Steudten 2006-04-22 13:17:33 EDT
DRM/DRI now works for me with:

mesa-libGLU-devel-6.4.2-6
mesa-libGL-devel-6.5-4
mesa-libGL-6.5-4
mesa-libGLU-6.4.2-6
xorg-x11-drv-ati-6.6.0-1
kernel-2.6.16-1.2147self_FC5

And the broken Icons are ok again, I think with the kernel-2147.
Just DRM errors with glx calls, like glxgears.
Comment 22 Michail V. 2006-05-04 19:25:30 EDT
DRM/DRI works for me too:

Definitely kernel problem.......

Hello i just configured my card with DRI 
(ATI Mobility Radeon 9100 IGP   chipset NS300M ).

until the last kernel of FC5:
    2.6.16-1.2107_FC5
I had the same problems as Thomas describes previously,
I had checked everything from drivers to Mesa packages 
and searching for the paths that glxinfo was using....

after the last post of Thomas I realised that the problem
was with the kernels in FC5 no I was just waiting for the
new updates in kernel. Today i installed from Rawhide the following
kernel:

kernel-2.6.16-1.2187_FC6.rpm

withouth changing anything in X confs or looking for problems
in Mesa libraries, DRI worked from the FIRST BOOT.

instead of the one line that was appearing in FC5s kernel from the
command : dmesg | grep drm

now I get the following :) :
------------------------------------------------------------------
[root@localhost ~]# dmesg | grep drm
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized radeon 1.24.0 20060225 on minor 0
[drm] Setting GART location based on old memory map
[drm] Loading R200 Microcode
[drm] writeback test succeeded in 1 usecs
[drm] Setting GART location based on old memory map
[drm] Loading R200 Microcode
[drm] writeback test succeeded in 1 usecs
-------------------------------------------------------------------

the radeon driver is being loaded perfectly with DRI and EXA at the
same time in X11R7. :)

for perfomance I can tell you that now my card gives me from
glxgears:  2635 frames in 5.0 seconds = 526.857 FPS

which is actually very good when you have used at 100FPS without 
DRI :)

have a nice day,

michail

Note You need to log in before you can comment on or make changes to this bug.