Bug 186168 - drivel EphySpinner not working
Summary: drivel EphySpinner not working
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: drivel   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Paul W. Frields
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-21 23:05 UTC by Paul W. Frields
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.10-0.2.20060527cvs.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 23:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 328109 None None None Never

Description Paul W. Frields 2006-03-21 23:05:58 UTC
Description of problem:
Some invalid casts cause the "spinner" graphic not to work properly in FC5. 
Example output follows:

(drivel:20941): libglade-WARNING **: could not find widget creation function

(drivel:20941): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to
`EphySpinner'



Version-Release number of selected component (if applicable):
2.0.2-2.fc5

How reproducible:
Every time.

Steps to Reproduce:
1. Open drivel program.
2. Look for "[custom widget creation failed]" message

  
Actual results:
No spinner picture.  Some other features may be missing as well.


Expected results:
Spinner and other custom widgets should work.

Additional info:
Packager will refer upstream for help.

Comment 1 Toshio Kuratomi 2006-05-03 17:29:11 UTC
This bug is related to GNOME bugzilla: 328109

On i386, this merely results in custom widgets (ephyspinner and egg_datetime)
not showing up.  On x86_64, there is a segfault.  The segfault is triggered by
this bug but its root cause may be in libglade (I proposed that theory to
upstream and am awaiting a reply.)

Comment 2 Paul W. Frields 2006-05-03 21:37:09 UTC
This has been fixed in CVS HEAD for drivel and upstream expects a new "official"
release shortly.

Comment 3 Toshio Kuratomi 2006-05-03 23:25:06 UTC
I confirm that drivel's CVS HEAD no longer triggers the bug on x86_64.  drivel
HEAD does not crash on login on x86_64.

Comment 4 Toshio Kuratomi 2006-06-14 14:30:37 UTC
I've prodded upstream for a new release as this bug makes drivel useless on x86_64.

Comment 5 Toshio Kuratomi 2006-07-21 23:58:34 UTC
The cvs snapshot is working like a charm.  Closing the bug.

Thanks Paul!


Note You need to log in before you can comment on or make changes to this bug.